平成29年秋 ネットワークスペシャリスト試験受験体験記

昨日は平成29年秋のネットワークスペシャリスト試験を受験してまいりました。
2年以上高度試験を受けていなかったので午前I免除なしで受けました。
丸一日拘束されるのはやっぱ疲れますね。。。
下記に私の中途半端な解答置いておくので、興味ある方はご覧ください。

テーマ

  1. 午前I (共通)
  2. 午前II NW用
  3. 午後I SSL-VPN, VDI導入でのトラフィック変化, クラウド事業者との VPN 接続と OSPF, BGP に関する知識を問う問題
  4. 午後II SDN, 無線LAN環境への移行

解答直リンク

  1. 午前I (共通) IPA 公式 https://www.jitec.ipa.go.jp/1_04hanni_sukiru/mondai_kaitou_2017h29_2/2017h29a_koudo_am1_ans.pdf
  2. 午前II NW用 IPA 公式 https://www.jitec.ipa.go.jp/1_04hanni_sukiru/mondai_kaitou_2017h29_2/2017h29a_nw_am2_ans.pdf
  3. 午後I iTEC 速報 https://www.itec.co.jp/wp-content/uploads/shiken/2017a/2017a_nw_pm1_kaito.pdf
  4. 午後II iTEC 速報 https://www.itec.co.jp/wp-content/uploads/shiken/2017a/2017a_nw_pm2_kaito.pdf

IPA の公式解答はこちら(午後はまだ)

所感

午前試験

午前試験は過去問対策やってればどちらも解ける問題が多めでした。
応用情報受かる人ならネットワーク部分だけ重点的に過去問復習すれば余裕で突破できると思いました。

午後試験

午後試験で選択した問題は明らかにわからないという内容ではなかったので、受かったらいいなあという気持ちです。
SDN は全然明るくない技術なのと物量的に解ける気がしない内容だったので選択しませんでした。

ネットワークのトポロジや設計のデザインパターンの概要がわかるので、具体的なコンフィグには落とし込めませんが、それなりに有意な試験内容だったと思います。

コラム

ちなみに電話の呼量を表すアーランという単位がありますが、電話網で言語として Erlang (ないし Elixir ) が使われているので、ネーミング的にそういうのが浸透してるのかなと思いました。
あと、一回提出して点数の変化のしようがないのに自己採点して一喜一憂する行為、なんなんですかね。

やっと試験から開放されました。

次は CCIE R&S とりたいです。

CCIE Routing and Switching Certification Planning Memo

私用のリンク集です。

CertificationPlan – Google スプレッドシート
Networking_Data_Sheets – Google スプレッドシート
CCIE_R&S_CertificationPlan – Google スプレッドシート

Blueprint

400-101 CCIE Routing and Switching – Cisco
Exam Topics – The Cisco Learning Network

PDF
https://learningcontent.cisco.com/cln_storage/text/cln/marketing/exam-topics/400-101-w-cciers-v51.pdf

学習方法情報収集

CCIEの学習方法
CCIE ( Cisco Certified Internetwork Expert ) R&S 勉強方法
11ヶ月でCCIEラボに合格する為の効果的な勉強方法
CCIE書籍レビュー:初めはこの本を買いましょう。理由3つ
CCNAからCCIE合格までの勉強時間、約1200時間でした
CCNAからCCIEラボ試験合格までの学習期間
CCIE R&S CCO (cisco.com) 公式ドキュメント

CCIE学習の流れ 1:基礎固め

Blueprint を確認する。

CCIE Routing and Switching – Cisco
400-101 CCIE Routing and Switching – Cisco
CCIE R&S 筆記試験の内容 – 29406 – The Cisco Learning Network
CCIE R&S ラボ試験 – 23061 – The Cisco Learning Network

5ch を確認する

Step1:CCNAイージス

CCNAイージス:CCNA(100-105J、200-105J、200-125J)Web教科書

Step2:CCNPイージス

CCNPイージス:CCNP SWITCH(300-115J)と ROUTE(300-101J)のWeb教科書

Step3:CCIE試験範囲( QoS )

◆ QoSをはじめから

QoS(Quality of Service)技術解説

◆ QoS – CatalystスイッチのQoS

Catalyst QoS 技術解説

◆ QoS技術の完全解説

QoS技術の完全解説

Step4:CCIE試験範囲( マルチキャスト )

◆ マルチキャストの基礎技術

マルチキャストの技術解説(基礎)

◆ マルチキャストの応用技術

マルチキャストの技術解説(応用)

◆ マルチキャストコンフィグレーション解説

マルチキャスト – Ciscoコンフィグ設定

◆ あわせてブログ記事の「 マルチキャストの完全解説」もご参考下さい。

マルチキャストの完全解説

Step5:CCIE試験範囲( MPLS )

◆ MPLSをはじめから(基礎解説)

MPLSとは

◆ MPLS – CCIE参考書 1

Amazon.co.jp: MPLS Fundamentals 電子書籍: Luc De Ghein: Kindleストア

◆ MPLS – CCIE参考書 2

Amazon.co.jp: MPLS Configuration on Cisco IOS Software (paperback) (Networking Technology): Umesh Lakshman, Lancy Lobo: 洋書
MPLS Configuration on Cisco IOS Software

※ MPLSをマスターしなければCCIEラボに合格できないので、洋書でしっかり学習を!

CCIE学習の流れ 2:筆記試験だけで出題される技術を学習

Step6:CCIE筆記試験の範囲( Integrated IS-IS )

◆ Integrated IS-ISの技術 – ラボ試験では範囲外

Integrated IS-IS | ネットワークエンジニアとして

Step7:CCIE筆記試験の範囲( NW仮想化技術 )

◆ NW仮想化の技術 – VRF以外はラボ試験では範囲外

NW仮想化技術 | ネットワークエンジニアとして

Step8:CCIE筆記試験の範囲( Cloud、SDN、IoT )

◆ Cloud、SDN、IoTの技術 – ラボ試験では範囲外

仮想化技術をはじめから

◆ こちらも参考

Cloud / SDN / IoT技術解説

CCIE学習の流れ 3:公式本を読む

Step1 ~ Step8まで学習していればとても読みやすくなっている

Step9:CCIE試験範囲( 全般 )

Amazon.co.jp: CCIE Routing and Switching v5.0 Official Cert Guide Library 電子書籍: Narbik Kocharians, Peter Paluch: Kindleストア

CCIE学習の流れ 4:ラボで役立つ実践的な学習

ここまで学習できれば、以下の学習方法をおこなう

Step10:ラボ試験を一発合格するためのオーソドックスな学習

■ CCIE対策の洋書の Cisco Press( CCIE参考書 )を熟読

お勧めのCCIE参考書

■ CCOの熟読、試験範囲のバージョンのマニュアルを熟読

CCIE R&S CCO (cisco.com) 公式ドキュメント

■ ワークブック(INE)で反復演習、実機での数多くの動作検証

CCIE Routing & Switching Training – INE
CCIE Routing & Switching Training Bundles – INE

[WIP]YubiKey

とりあえず YubiKey 4 だけ買った。
Windows 10 Pro の Windows Hello デバイスとして使った。
Windows ストアアプリを入れたけど起動時のログオンのタイミングでは動作せず、ロック解除するタイミングで挿入しないと動作しないっぽい。

  1. ワンタイムパスワードトークンYubiKey |(株)ソフト技研
  2. Yubikey入門 | Developers.IO
  3. 秘密鍵、管理してますか? YubiKeyで鍵の一元管理とSSH接続、2段階認証の高速化を試す – Qiita
  4. YubiKeyの予備キー – Qiita
  5. YubiKeyでTOTP – Qiita
  6. YubiKey製品一覧 | CloudGate
  7. YubiKey Edge で 2段階認証 ~ Windows10編 – Qiita
  8. Getting Started with YubiKey | Yubico
  9. Windows | Yubico
  10. YubiKey Works With Windows Hello | Yubico
  11. Buy YubiKey for Windows Hello – Microsoft Store
  12. Downloads Archives | Yubico
  13. パスワードは時代遅れです:Windows 10時代の新認証 「Windows Hello/Microsoft Passport」と「FIDO」を理解する (1/5) – ITmedia エンタープライズ
  14. yubikeyでセキュリティ筋力を鍛える · JoeMPhilips

LPIC2 略語メモ

DSO(Dynamic Shared Object)
ISC(Internet Software Consortium)
PDC(Primary Domain Controller)
BDC(Backup Domain Controller)
LDIF(LDAP Data Interchange Format)
vsftpd(Very Secure FTP Daemon)
DC(Domain Component)
cn(Common Name)
DIT(Directory Information Tree)
ou(Organizational Unit Name)

LPIC2: Linux カーネル

[root@px-lpic1-centos6 ~]# find /lib/modules/`uname -r`/kernel -name "*.ko" | head
/lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/lockd/lockd.ko
/lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/squashfs/squashfs.ko
/lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/udf/udf.ko
/lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/autofs4/autofs4.ko
/lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/jffs2/jffs2.ko
/lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/exportfs/exportfs.ko
/lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/nfs_common/nfs_acl.ko
/lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/gfs2/gfs2.ko
/lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/ext4/ext4.ko
/lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/jbd/jbd.ko
[root@px-lpic1-centos6 ~]# modinfo ext4
filename:       /lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/ext4/ext4.ko
license:        GPL
description:    Fourth Extended Filesystem
author:         Remy Card, Stephen Tweedie, Andrew Morton, Andreas Dilger, Theodore Ts'o and others
srcversion:     74AEE2BDA63AC8482A78F4D
depends:        mbcache,jbd2
vermagic:       2.6.32-696.3.1.el6.x86_64 SMP mod_unload modversions
[root@px-lpic1-centos6 ~]# lsmod | head
Module                  Size  Used by
autofs4                27000  3
8021q                  20475  0
garp                    7152  1 8021q
stp                     2218  1 garp
llc                     5418  2 garp,stp
ipt_REJECT              2383  2
nf_conntrack_ipv4       9186  2
nf_defrag_ipv4          1483  1 nf_conntrack_ipv4
iptable_filter          2793  1
[root@px-lpic1-centos6 ~]# find /lib/modules/`uname -r`/kernel -name "autofs4.ko"
/lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/autofs4/autofs4.ko
[root@px-lpic1-centos6 ~]# find /lib/modules/`uname -r`/kernel -name "autofs4.ko" | xargs ls -lh
-rwxr--r--. 1 root root 58K  5月 31 05:07 2017 /lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/autofs4/autofs4.ko
[root@px-lpic1-centos6 ~]# cat /proc/modules | head
autofs4 27000 3 - Live 0xffffffffa0578000
8021q 20475 0 - Live 0xffffffffa056e000
garp 7152 1 8021q, Live 0xffffffffa0568000
stp 2218 1 garp, Live 0xffffffffa0564000
llc 5418 2 garp,stp, Live 0xffffffffa055e000
ipt_REJECT 2383 2 - Live 0xffffffffa0533000
nf_conntrack_ipv4 9186 2 - Live 0xffffffffa052c000
nf_defrag_ipv4 1483 1 nf_conntrack_ipv4, Live 0xffffffffa0528000
iptable_filter 2793 1 - Live 0xffffffffa0524000
ip_tables 17895 1 iptable_filter, Live 0xffffffffa051b000
[root@px-lpic1-centos6 ~]# modinfo -a ext4
Remy Card, Stephen Tweedie, Andrew Morton, Andreas Dilger, Theodore Ts'o and others
[root@px-lpic1-centos6 ~]# modinfo -d ext4
Fourth Extended Filesystem
[root@px-lpic1-centos6 ~]# modinfo -l ext4
GPL
[root@px-lpic1-centos6 ~]# modinfo -n ext4
/lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/ext4/ext4.ko
[root@px-lpic1-centos6 ~]# modinfo ext4
filename:       /lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/ext4/ext4.ko
license:        GPL
description:    Fourth Extended Filesystem
author:         Remy Card, Stephen Tweedie, Andrew Morton, Andreas Dilger, Theodore Ts'o and others
srcversion:     74AEE2BDA63AC8482A78F4D
depends:        mbcache,jbd2
vermagic:       2.6.32-696.3.1.el6.x86_64 SMP mod_unload modversions
[root@px-lpic1-centos6 ~]# lsmod | grep xfs
[root@px-lpic1-centos6 ~]# modinfo xfs
filename:       /lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/xfs/xfs.ko
license:        GPL
description:    SGI XFS with ACLs, security attributes, large block/inode numbers, no debug enabled
author:         Silicon Graphics, Inc.
srcversion:     06CA178475DC4F7F5169D42
depends:        exportfs
vermagic:       2.6.32-696.3.1.el6.x86_64 SMP mod_unload modversions
[root@px-lpic1-centos6 ~]# lsmod | grep exportfs
[root@px-lpic1-centos6 ~]# modinfo exportfs
filename:       /lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/exportfs/exportfs.ko
license:        GPL
srcversion:     1CA651A66F2E2EBCEAD08AC
depends:
vermagic:       2.6.32-696.3.1.el6.x86_64 SMP mod_unload modversions
[root@px-lpic1-centos6 ~]# insmod /lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/exportfs/exportfs.ko
[root@px-lpic1-centos6 ~]# lsmod | grep exportfs
exportfs                4236  0
[root@px-lpic1-centos6 ~]# rmmod /lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/exportfs/exportfs.ko
# xfs カーネルモジュールは exportfs カーネルモジュールに依存しているので先に exportfs カーネルモジュールをロードする必要がある
[root@px-lpic1-centos6 ~]# insmod /lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/xfs/xfs.ko
insmod: error inserting '/lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/xfs/xfs.ko': -1 Unknown symbol in module
[root@px-lpic1-centos6 ~]# insmod /lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/exportfs/exportfs.ko
[root@px-lpic1-centos6 ~]# insmod /lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/xfs/xfs.ko
[root@px-lpic1-centos6 ~]# lsmod | egrep "(exportfs|xfs)"
xfs                  1135639  0
exportfs                4236  1 xfs
[root@px-lpic1-centos6 ~]# rmmod exportfs
ERROR: Module exportfs is in use by xfs
[root@px-lpic1-centos6 ~]# rmmod -s exportfs
[root@px-lpic1-centos6 ~]# tail -n1 /var/log/messages
Jul  7 08:52:00 px-lpic1-centos6 rmmod: ERROR: Module exportfs is in use by xfs

modprobe

[root@px-lpic1-centos6 ~]# rmmod xfs
[root@px-lpic1-centos6 ~]# rmmod exportfs
[root@px-lpic1-centos6 ~]# modprobe xfs
[root@px-lpic1-centos6 ~]# modprobe -r xfs
[root@px-lpic1-centos6 ~]# lsmod | egrep "(exportfs|xfs)"
[root@px-lpic1-centos6 ~]# modprobe xfs
[root@px-lpic1-centos6 ~]# lsmod | egrep "(exportfs|xfs)"
xfs                  1135639  0
exportfs                4236  1 xfs
[root@px-lpic1-centos6 ~]# modprobe -r xfs
[root@px-lpic1-centos6 ~]# lsmod | egrep "(exportfs|xfs)"
[root@px-lpic1-centos6 ~]# modprobe -lt fs | head
kernel/fs/nfs_common/nfs_acl.ko
kernel/fs/nls/nls_cp737.ko
kernel/fs/nls/nls_cp775.ko
kernel/fs/nls/nls_cp850.ko
kernel/fs/nls/nls_cp852.ko
kernel/fs/nls/nls_cp855.ko
kernel/fs/nls/nls_cp857.ko
kernel/fs/nls/nls_cp860.ko
kernel/fs/nls/nls_cp861.ko
kernel/fs/nls/nls_cp862.ko
[root@px-lpic1-centos6 ~]# modprobe --show-depends ext3
insmod /lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/mbcache.ko
insmod /lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/jbd/jbd.ko
insmod /lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/ext3/ext3.ko
[root@px-lpic1-centos6 ~]# modinfo ext3
filename:       /lib/modules/2.6.32-696.3.1.el6.x86_64/kernel/fs/ext3/ext3.ko
license:        GPL
description:    Second Extended Filesystem with journaling extensions
author:         Remy Card, Stephen Tweedie, Andrew Morton, Andreas Dilger, Theodore Ts'o and others
srcversion:     CF8EACB0D78355F028912B4
depends:        mbcache,jbd
vermagic:       2.6.32-696.3.1.el6.x86_64 SMP mod_unload modversions

IPv6

  1. 対応ページ: pp.440-473
  2. 対応試験: CCNPv2.0 Routing and Switching 300-101J ROUTE
  3. カテゴリ: IPv6
  4. サブカテゴリ: なし
  5. IOS: c3725-adventerprisek9-mz.124-15.T14.bin
  6. Cisco ISR 1841, IOS: c1841-adventerprisek9-mz.151-4.M10.bin

グローバルユニキャストアドレス 2000::/3
ユニークローカルユニキャストアドレス FC00::/7 Effectively FD00::/8
リンクローカルユニキャストアドレス FE80::/10

インターフェイスID

EUI-64
64bit Extended Unique Identifier

MACアドレス(EUI-48)

U/L(Universal/Local) ビット

匿名アドレス(一時アドレス) RFC3041
RFC 3041 – Privacy Extensions for Stateless Address Autoconfiguration in IPv6

マルチキャストアドレス

FF00::/8

エニーキャストアドレス

最も近いノードとの通信。

IPv6 ルート集約

IPv6 アドレスの割り当て

手動設定

ステートレスアドレス自動設定(オートコンフィギュレーション)

RFC2462

ネットワークに接続するとルータからプレフィックスが通知される。

近隣探索プロトコル(NDP; Neighbor Discovery Protocol) を使用する。
RS/RA

Router Solicitation

Router Advertisement

主要なプロトコル

ICMPv6

RFC2463
RFC2470
RFC2461

近隣探索プロトコル(NDP)

Neighbor Discovery Protocol

RFC4861

Router Solicitation(RS)
Router Advertisement(RA)

Neighbor Solicitation(NS)
Neighbor Advertisement(NA)

要請ノードマルチキャストアドレスへの参加義務

R1(config)#do sh run | i ipv6
ipv6 unicast-routing
ipv6 cef
R1(config)#ipv6 unicast-routing
R3#sh run | i ipv6
no ipv6 cef
R2(config)#ipv6 unicast-routing
en
conf t
int f0/0
no shut
int f0/1
no shut
end


en
conf t
int f0/0
no shut
end

en
conf t
int f0/0
no shut
end

en
conf t
int f0
no shut
end

en
conf t
int f0
no shut
end

IPv6 の有効化

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ipv
R1(config)#ipv6 unica
R1(config)#ipv6 unicast-routing
R1(config)#int f0/0
R1(config-if)#ipv
R1(config-if)#ipv6 ena
R1(config-if)#ipv6 enable
R1(config-if)#do sh ipv
% Ambiguous command:  "do sh ipv"
R1(config-if)#do sh ipv6 int
FastEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::21B:2AFF:FE77:66D2
  No Virtual link-local address(es):
  No global unicast address is configured
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF77:66D2
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds (using 30000)
  ND advertised reachable time is 0 (unspecified)
  ND advertised retransmit interval is 0 (unspecified)
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  ND advertised default router preference is Medium
  Hosts use stateless autoconfig for addresses.

グローバルユニキャストアドレスの設定

R1(config-if)#ipv6 address 2001:1:1:1::/64 eui-64
R1(config-if)#do sh ipv6 int
FastEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::21B:2AFF:FE77:66D2
  No Virtual link-local address(es):
  Global unicast address(es):
    2001:1:1:1:21B:2AFF:FE77:66D2, subnet is 2001:1:1:1::/64 [EUI]
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF77:66D2
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds (using 30000)
  ND advertised reachable time is 0 (unspecified)
  ND advertised retransmit interval is 0 (unspecified)
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  ND advertised default router preference is Medium
  Hosts use stateless autoconfig for addresses.

リンクローカルアドレスをわかりやすいアドレスに変更する。

f0/0 において FE80::1 としよう。

R1(config-if)#ipv6 address FE80::1 link-local
R1(config-if)#do sh ipv6 int f0/0
FastEthernet0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::1
  No Virtual link-local address(es):
  Global unicast address(es):
    2001:1:1:1::1, subnet is 2001:1:1:1::/64 [EUI]
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF00:1
  MTU is 1500 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds (using 30000)
  ND advertised reachable time is 0 (unspecified)
  ND advertised retransmit interval is 0 (unspecified)
  ND router advertisements are sent every 200 seconds
  ND router advertisements live for 1800 seconds
  ND advertised default router preference is Medium
  Hosts use stateless autoconfig for addresses.

上記トポロジのように設定してみる。
インターフェイス名はちょっと違うのでご注意。

conf t
int f0/0
ipv6 enable
ipv6 address 2001:1:1:1::/64 eui-64
ipv6 address FE80::1 link-local
int f0/1
ipv6 enable
ipv6 address FE80::1:1 link-local
end

conf t
int f0/0
ipv6 enable
ipv6 address 2001:1:1:1::/64 eui-64
ipv6 address FE80::2 link-local
end

conf t
int f0/0
ipv6 enable
ipv6 address FE80::3 link-local
end

conf t
int f0
ipv6 enable
ipv6 address FE80::1:4 link-local
end

conf t
int f0
ipv6 enable
ipv6 address FE80::1:5 link-local
end

設定が終わったこのとき、 IPv6 ネイバーテーブルを確認すると空っぽ。

R2#sh ipv6 neighbors

ping を打ってみる。

リンクローカルアドレスは出力インターフェイスも指定する必要がある。

出力インターフェイス名は省略形ではなくスペース無しで完全なインターフェイス名を書く必要があるようだ。

R2#ping FE80::1
Output Interface:
% Interface required
R2#ping FE80::1 ?
data specify data pattern
repeat specify repeat count
size specify datagram size
source specify source address or name
timeout specify timeout interval
verbose verbose output

R2#ping FE80::1
Output Interface: f0/0
% Invalid interface. Use full interface name without spaces (e.g. Serial0/1)
Output Interface: FastEthernet0/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::1, timeout is 2 seconds:
Packet sent with a source address of FE80::2%FastEthernet0/0
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/1/8 ms

出力の例を見ると % 記述でつなげて出力インターフェイス名を指定できるみたいだ。
YAMAHA でもそんな感じでできた気がする。

R2#ping FE80::1%f0/0
% Unrecognized host or address, or protocol not running.

R2#ping FE80::1%FastEthernet0/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::1, timeout is 2 seconds:
Packet sent with a source address of FE80::2%FastEthernet0/0
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/4 ms

R2#sh ipv6 neighbors
IPv6 Address Age Link-layer Addr State Interface
FE80::1 0 001b.2a77.66d2 REACH Fa0/0

対向の R1 でもネイバーテーブルにキャッシュされる。

R1#sh ipv6 neighbors
IPv6 Address Age Link-layer Addr State Interface
FE80::2 3 0024.c431.126e STALE Fa0/0

グローバルユニキャストアドレス、ならびにユニークローカルユニキャストアドレスは出力インターフェイスを指定する必要はない。

R1#sh ipv6 int f0/0
FastEthernet0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::1
No Virtual link-local address(es):
Global unicast address(es):
2001:1:1:1::1, subnet is 2001:1:1:1::/64 [EUI]
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF00:1
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ICMP unreachables are sent
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds (using 30000)
ND advertised reachable time is 0 (unspecified)
ND advertised retransmit interval is 0 (unspecified)
ND router advertisements are sent every 200 seconds
ND router advertisements live for 1800 seconds
ND advertised default router preference is Medium
Hosts use stateless autoconfig for addresses.

R2#sh ipv6 int
FastEthernet0/0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::2
No Virtual link-local address(es):
Global unicast address(es):
2001:1:1:1::2, subnet is 2001:1:1:1::/64 [EUI]
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF00:2
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ICMP unreachables are sent
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds (using 30000)
ND advertised reachable time is 0 (unspecified)
ND advertised retransmit interval is 0 (unspecified)
ND router advertisements are sent every 200 seconds
ND router advertisements live for 1800 seconds
ND advertised default router preference is Medium
Hosts use stateless autoconfig for addresses.

R1#ping 2001:1:1:1::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:1:1::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/1/8 ms

こうするとグローバルユニキャストアドレスも IPv6 ネイバーテーブルにのるようになる。

R2#sh ipv6 neighbors
IPv6 Address                              Age Link-layer Addr State Interface
2001:1:1:1::1                               0 001b.2a77.66d2  REACH Fa0/0
FE80::1                                     9 001b.2a77.66d2  DELAY Fa0/0

Windows の GNS3 で Cisco ルーターの設定を初期化する

GNS3 上でトポロジを構成する際、誤ったコンフィグを投入してしまって、あまつさえ保存してしまったとします。
こういった場合設定を初期化したいのですが、 erase startup-config だけだとルーターのホスト名の設定やロギングの挙動の調整といった、
ルーター初回起動時に投入される便利なコンフィグが読み込まれません。
最低限ルーター名だけでも最初から投入してくれないとわかりにくくて大変です。
GNS3 のドキュメント探してみましたが相当するようなドキュメントが見つからなかったので結構苦労しました。

トポロジを構成するルーターが 1, 2 台ならプロジェクト作り直せばいいかで済むんですが、 5 台以上になってくると大変です。
トポロジを作るのに加えてインターフェイスのラベルの位置とか微調整しているので作り直しってなったら発狂したくなります。

つーか、 Mac 版だと コンフィグ消したら NVRAM が勝手に初期化されたから、 Windows 版のバグのような気がしないでもない。

R1#erase startup-config
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: complete
R1#
*Mar  1 00:00:26.751: %SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram

誰か教えて下しあ。。。
GNS3 のドキュメントに載ってるのかな。。
今度腰を据えて GNS3 のドキュメント読もうかな。
というか GNS3 2.0 RC2 までいったようで、熱いね。
もうリリース間近といった感じ。

Releases · GNS3/gns3-gui

以下は Windows 版でのみの話し

ルーター上で

erase startup-config

これでルーターを再起動しても初回起動時に投入されるコンフィグは入らない。
ホスト名も設定されていない完全にまっさらに初期化されたルーターが起動される。
まあ、物理的なルーターの動作としてはこれが正しいんだが、コンセプトを理解したい場合は違う、そうじゃないとなる。

次に、ルーターを停止させる。これ重要。

右クリックでコンフィグをインポートする。

Windows なら

C:\Users\wnoguchi\GNS3\configs\ios_base_startup-config.txt

Mac なら

/Users/wnoguchi/GNS3/configs/ios_base_startup-config.txt

Linux なら(エスパーしている)

/home/GNS3/configs/ios_base_startup-config.txt

ちなみにコンフィグは以下のような感じになっていた。

!
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname %h
!
ip cef
no ip domain-lookup
no ip icmp rate-limit unreachable
ip tcp synwait 5
no cdp log mismatch duplex
!
line con 0
 exec-timeout 0 0
 logging synchronous
 privilege level 15
 no login
line aux 0
 exec-timeout 0 0
 logging synchronous
 privilege level 15
 no login
!
!
end

%h の部分がホスト名に置換されているわけですな。

プライベートコンフィグは読み込まなくて良い。

そしてルーター起動。

これで OK 。

OSPF 認証 インターフェイス認証

  1. 対応ページ: pp.222-225
  2. 対応試験: CCNPv2.0 Routing and Switching 300-101J ROUTE
  3. カテゴリ: OSPF
  4. サブカテゴリ: OSPF 認証 インターフェイス認証
  5. IOS: c3725-adventerprisek9-mz.124-15.T14.bin

OSPF認証について

OSPF認証タイプ

  • タイプ0 Null 認証
  • タイプ1 シンプルパスワード認証
  • タイプ2 MD5 認証

ネイバー認証の設定対象

  • インターフェイス
  • エリア
  • 仮想リンク

トポロジ

GNS3 プロジェクトファイルダウンロード

OSPF 認証設定前までやってあります。

GNS3 1.5.x では Windows, Mac 間の portable project のエクスポート、インポートがうまくいかない | | wnoguchi’s diary

Windows

ospf-authentication-interface

Mac

TODO

基本設定

R1

conf t
int f0/0
ip addr 10.0.12.1 255.255.255.0
no shut
!
! OSPF configuration
router ospf 1
router-id 1.1.1.1
network 10.0.0.0 0.255.255.255 area 0
end
wr

R2(ABR)

conf t
int f0/0
ip addr 10.0.12.2 255.255.255.0
no shut
int s0/0
ip addr 10.1.23.2 255.255.255.0
no shut
!
! OSPF configuration
router ospf 1
router-id 2.2.2.2
network 10.0.0.0 0.0.255.255 area 0
network 10.1.0.0 0.0.255.255 area 1
end
wr

R3

conf t
int s0/0
ip addr 10.1.23.3 255.255.255.0
no shut
!
! OSPF configuration
router ospf 1
router-id 3.3.3.3
network 10.0.0.0 0.255.255.255 area 1
end
wr

VPCs

なし

設定前の動作確認

なし

設定

R1

conf t
int f0/0
ip ospf authentication
ip ospf authentication-key CISCO

R2(ABR)

conf t
int f0/0
ip ospf authentication
ip ospf authentication-key CISCO
int s0/0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 ROUTE

R3

conf t
int s0/0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 ROUTE

検証

インターフェイスで認証が有効になっていることを確認する。

シンプルパスワード認証

R2#sh ip ospf int f0/0
FastEthernet0/0 is up, line protocol is up
  Internet Address 10.0.12.2/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 10.0.12.2
  Backup Designated router (ID) 1.1.1.1, Interface address 10.0.12.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 2
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 1.1.1.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
  Simple password authentication enabled

MD5 認証

R2#sh ip ospf int f0/0
FastEthernet0/0 is up, line protocol is up
  Internet Address 10.0.12.2/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 10.0.12.2
  Backup Designated router (ID) 1.1.1.1, Interface address 10.0.12.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 2
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 1.1.1.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
  Simple password authentication enabled

ネイバーテーブルを確認して所望のネイバーが認識されていることを確認する。

R2#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        00:00:37    10.0.12.1       FastEthernet0/0
3.3.3.3           0   FULL/  -        00:00:33    10.1.23.3       Serial0/0

おことわり

これは「徹底攻略Cisco CCNP Routing & Switching ROUTE教科書[300-101J]対応 徹底攻略シリーズ」に掲載されているサンプルトポロジのコンフィグを自分で考えて、インターフェイスの対応等微妙に変えて GNS3, あるいは VIRL のプロジェクトファイルとしています。
具体的な説明はここではせず、箇条書き程度の自分用のメモ、コンフィグ、実際の出力結果を載せています。
詳細なコンセプトの説明はこのテキストを参照するか、他のサイトをあたることをおすすめします。

追記

コンフィグやトポロジに誤りがありましたら指摘いただけるとうれしいです!

なんでこんなこと書いているか

Cisco の試験に限らないですけど、私の基本的なスタンスを書いてあります。
随時アップデートしていくので興味あったら覗いてみてください。

Cisco の技術者認定試験における私のスタンス | wnoguchi’s diary

参考書紹介

こちらのテキストを使用させていただいております。
いつもありがとうございます。

個人的なおすすめはテキストは紙版と Kindle 版両方買っておいて、ウォークスルー的なテキストの読み込みは
クロスリファレンスが必要なときは紙の本をざっと開くのがおすすめです。
問題集は紙版さえあればいいかなと思ってますが、もしかすると Kindle 版のほうが効率いいのかも。
どうなんだろ。

GNS3 1.5.x では Windows, Mac 間の portable project のエクスポート、インポートがうまくいかない

ご注意: GNS3 1.5 系のポータブルプロジェクトファイルは私が試した限り Windows と Mac 間では互換性がありません。

それと Windows 間のインポートだとエクスポート元で GNS3 VM 上で実行していたやつでも、インポート先だとローカルの Dynamips で実行されてしまうっぽい。。。
設定の問題なのかなあ。。。

最初この事実を知った時、うーんって感じでした。
まあ、マルチプラットフォームの難しさは推して量るべしですが・・・。
こういったコミュニティに積極的にコミットできるようになりたい。