Adobe CC (Creative Cloud) の Photoshop でモザイクかける

スクショをとった画像に外に公開するときは見せたくない部分にモザイクかけることってよくありますよね。
いや、それぐらいなら Skitch やら Screenpresso 使えよって話ですけどね。
Adobe CC サブスクリプション使ってる身としては活用せねば金を溝に捨ててるのと同じなわけです。
最近クライアントソフトウェア販売手法でも大流行中のサブスクリプション商法。
MSDN はいわずもがな Adobe も JetBrains も Office365 もサブスクリプション。
クラウド時代の宿命。
ほんとえげつない商売ですねえ。
売る側としては笑いが止まらんでしょうな。

さて本題に入ると

作業環境は Mac を想定。でも基本的な使い方を誤らなければ OK 。

選択ツールでモザイクかけたい範囲をドラッグアンドドロップで選択します。
複数の領域を選択したい場合は Shift 押しながらやってください。

そうしたら、メニューから [フィルター] -> [ピクセレート] -> [モザイク] を選択します。

ScreenShot 2016-05-15 21.48.26

出てきたダイアログでモザイクのピクセルの粗さを指定して OK すればこれで完了。

ScreenShot 2016-05-15 21.50.19

以上です。

Cookie が無効になっていて MediaWiki にログインできないって言われた件

結論

セッションディレクトリが書込みできませんでした。

エラーメッセージ

ログインのエラー 
example wikiではログインに Cookie を使用します。 Cookie を無効にしているようです。 Cookie を有効にしてから、もう一度試してください。

当方の環境

  • さくらのVPS
  • CentOS7.2.1511 x86_64
  • Nginx + php-fpm
  • PHP 5.4

調べたこと

  • ログにも大したこと書いてない。
  • Cookie は無効になってない。
  • シークレットモードでやってみたけど同じ。
  • Cookie 消してみたけど変わらない。
  • パスワード再発行しても同じ。
  • ブラウザ変えてみたけど同じ。

ぐぐって調べてみるとセッションのディレクトリが書き込みできませんでした、てへ♪的なスレッドが見つかった。

なるほどな。

phpinfo() 出力させてセッション格納ディレクトリを調べる。

session.save_path = /var/lib/php/session

ディレクトリのパーミッションを確認。

[root@mx1 mediawiki]# ls -l /var/lib/php/
合計 4
drwxrwx--- 2 root apache 4096  5月 12 22:49 session
[root@mx1 mediawiki]# ls -l /var/lib/php/session/
合計 64
-rw------- 1 nginx nginx 3436  3月 13 12:10 sess_29ih6fgffffffffff9ee024fa7
(snip)
-rw------- 1 nginx nginx   53  3月 19 07:57 sess_tpih6fgfffffork4bvffmff625

なんでグループが apache やねん!
そりゃ書き込めないはずだわ。
最近流行りに乗って Nginx 使ってるので Apache は使っていない。
ファイル自身は nginx 所有者で大丈夫っぽいな。
Ansible でメールサーバー構築する Playbook 開発してたからそれが原因かな。
念のため nginx と php-fpm の実行ユーザを確認する。

[root@mx1 mediawiki]# vim /etc/nginx/nginx.conf
[root@mx1 mediawiki]# vim /etc/php-fpm.d/www.conf
[root@mx1 mediawiki]# id nginx
uid=995(nginx) gid=993(nginx) groups=993(nginx)

対策実施

ディレクトリのグループを nginx に変更する。

[root@mx1 mediawiki]# chown root:nginx /var/lib/php/session
[root@mx1 mediawiki]# ls -l /var/lib/php/
合計 4
drwxrwx--- 2 root nginx 4096  5月 12 22:49 session

用が済んだら phpinfo のファイルは削除する。

[root@mx1 mediawiki]# rm -f phpinfo.php

これでちゃんとろぐいんできるようになりましたとさ。
めでたしめでたし。

参考リンク

  1. [RESOLVED] Cannot Login or Register. Enable Cookies on Project:Support desk
  2. Help:ログイン – MediaWiki

Ubuntu に open-vm-tools を入れる(VMware Workstation)

VMware Tools 入れようと思ったら open-vm-tools 入れろって言われた。
VMware Tools のオープンソース実装らしい。
だったら VMware Tools の tarball 展開する前に言えって思ったけど、入れてみる。

URL に飛んでみたらダウンロードページらしきものが見当たらないので apt を検索してみたらあった。
それを入れる。
Linux 系は gcc やら他のものいろいろ入れないといけないので、コンパイル済みのバイナリを提供しているらしい。
デスクトップ環境なら -desktop を、 Server 環境の場合は無印(CLI版)を入れる。

sudo apt-get -y install open-vm-tools-desktop
  1. vmware/open-vm-tools: Official repository of VMware open-vm-tools project
  2. Linux仮想マシンでVMware Toolsではなくopen-vm-toolsを使う | 仮想(VMware & Hyper-V)/クラウド・エンジニア技術ブログ
  3. open-vm-tools – Google 検索

GNOME のディレクトリ名を日本語から英語に直す

もう何回同じこと検索しているのかわからないので記す。
RedHad 系(RHEL, Fedora, CentOS)、 Ubuntu であろうがなかろうが GTK 使ってるディスプレイマネージャはこの方法で修正できる。


LANG=C xdg-user-dirs-gtk-update

特に日本語ディレクトリ名にしょっちゅう里心がつく人でなければ二度と聞くなチェックボックスにチェックを入れる。
これで完了。

ホームディレクトリのフォルダ名を日本語から英語に変更するには - @IT

Ubuntu Server 14.04 LTS から 16.04 LTS にアップグレードした

最初はプレーンな Jenkins しか入っていないからクリーンインストールしたかったんだけど、
サーバマシンが古すぎるからなのか 16.04 のインストールイメージは NIC を認識しない。
ドライバを探してきて入れるのがだるいのでアップグレードすることに決めた。

まず以下のアップグレードマネージャを入れる。

$ sudo apt-get install update-manager-core

ここで一つ注意。

sudo vim /etc/update-manager/release-upgrades

Prompt=normal にする必要がある。

# Default behavior for the release upgrader.

[DEFAULT]
# Default prompting behavior, valid options:
#
#  never  - Never check for a new release.
#  normal - Check to see if a new release is available.  If more than one new
#           release is found, the release upgrader will attempt to upgrade to
#           the release that immediately succeeds the currently-running
#           release.
#  lts    - Check to see if a new LTS release is available.  The upgrader
#           will attempt to upgrade to the first LTS release available after
#           the currently-running one.  Note that this option should not be
#           used if the currently-running release is not itself an LTS
#           release, since in that case the upgrader won't be able to
#           determine if a newer release is available.
#Prompt=lts
Prompt=normal
wnoguchi@phy2:~$ sudo do-release-upgrade
Checking for a new Ubuntu release
Get:1 Upgrade tool signature [198 B]
Get:2 Upgrade tool [1230 kB]
Fetched 1230 kB in 0s (0 B/s)
authenticate 'wily.tar.gz' against 'wily.tar.gz.gpg'
extracting 'wily.tar.gz'
[screen is terminating]

Reading cache

Checking package manager

Continue running under SSH?

This session appears to be running under ssh. It is not recommended
to perform a upgrade over ssh currently because in case of failure it
is harder to recover.

If you continue, an additional ssh daemon will be started at port
'1022'.
Do you want to continue?

Continue [yN] N
=== Command terminated with exit status 1 (Thu May  5 13:20:06 2016) ===

まあ、 screen が立ち上がっているようなので、大丈夫みたいだが。

Ign http://us.archive.ubuntu.com trusty/main Translation-en_US
Ign http://us.archive.ubuntu.com trusty/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com trusty/restricted Translation-en_US
Ign http://us.archive.ubuntu.com trusty/universe Translation-en_US
Fetched 5,083 kB in 6s (13.6 MB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done

Updating repository information

Third party sources disabled

Some third party entries in your sources.list were disabled. You can
re-enable them after the upgrade with the 'software-properties' tool
or your package manager.

To continue please press [ENTER]

(snip)

Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done

Calculating the changes

Calculating the changes

Do you want to start the upgrade?


1 installed package is no longer supported by Canonical. You can
still get support from the community.

6 packages are going to be removed. 131 new packages are going to be
installed. 411 packages are going to be upgraded.

You have to download a total of 317 M. This download will take about
3 minutes with your connection.

Installing the upgrade can take several hours. Once the download has
finished, the process cannot be canceled.

 Continue [yN]  Details [d]y

ちょっと時間がかかる。

「libpam, libc, libssl とかのパッケージのインストール中はいくつかのサービスをリスタートする必要があるけど、なんにも聞かずにリスタートしてもいい?」と聞かれる。

 ┌────────────┤ Configuring libc6 ├──────────────┐
 │                                                                           │
 │ There are services installed on your system which need to be restarted    │
 │ when certain libraries, such as libpam, libc, and libssl, are upgraded.   │
 │ Since these restarts may cause interruptions of service for the system,   │
 │ you will normally be prompted on each upgrade for the list of services    │
 │ you wish to restart.  You can choose this option to avoid being           │
 │ prompted; instead, all necessary restarts will be done for you            │
 │ automatically so you can avoid being asked questions on each library      │
 │ upgrade.                                                                  │
 │                                                                           │
 │ Restart services during package upgrades without asking?                  │
 │                                                                           │
 │                    <Yes>                       <No>                       │
 │                                                                           │
 └──────────────────────────────────────┘

(snip)
Unpacking psmisc (22.21-2build1) over (22.20-1ubuntu2) ...
Preparing to unpack .../ubuntu-release-upgrader-core_1%3a15.10.14.4_all.deb ...
Unpacking ubuntu-release-upgrader-core (1:15.10.14.4) over (1:0.220.8) ...
Preparing to unpack .../python3-distupgrade_1%3a15.10.14.4_all.deb ...
Unpacking python3-distupgrade (1:15.10.14.4) over (1:0.220.8) ...
Preparing to unpack .../python3-update-manager_1%3a15.10.3_all.deb ...
Unpacking python3-update-manager (1:15.10.3) over (1:0.196.14) ...
Preparing to unpack .../update-manager-core_1%3a15.10.3_all.deb ...
Unpacking update-manager-core (1:15.10.3) over (1:0.196.14) ...
Preparing to unpack .../python3-gi_3.16.2-1build1_amd64.deb ...
Unpacking python3-gi (3.16.2-1build1) over (3.12.0-1ubuntu1) ...
Preparing to unpack .../rsync_3.1.1-3ubuntu0.15.10.1_amd64.deb ...
Unpacking rsync (3.1.1-3ubuntu0.15.10.1) over (3.1.0-2ubuntu0.2) ...
Preparing to unpack .../shared-mime-info_1.3-1_amd64.deb ...
Unpacking shared-mime-info (1.3-1) over (1.2-0ubuntu3) ...
Preparing to unpack .../tcpdump_4.7.4-1ubuntu1_amd64.deb ...
(snip)

いいよー。と答える。
すごく時間がかかる。


(snip)
Setting up command-not-found (0.3ubuntu15.10.1) ...
Installing new version of config file /etc/zsh_command_not_found ...
Setting up plymouth-theme-ubuntu-text (0.9.0-0ubuntu9) ...
update-initramfs: deferring update (trigger activated)
Setting up python3-distupgrade (1:15.10.14.4) ...
Setting up python3-update-manager (1:15.10.3) ...
Setting up ubuntu-release-upgrader-core (1:15.10.14.4) ...

Configuration file '/etc/update-manager/release-upgrades'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** release-upgrades (Y/I/N/O/D/Z) [default=N] ?N

パッケージのメンテナからのリリースのディストリバージョンに上げるかどうか聞かれる。
LTS から変えたくないので N と答える。


Remove obsolete packages?


25 packages are going to be removed.

 Continue [yN]  Details [d]y
Fetched 0 B in 0s (0 B/s)

(snip)

Processing triggers for man-db (2.7.4-1) ...
Processing triggers for libc-bin (2.21-0ubuntu4.1) ...

System upgrade is complete.

Restart required

To finish the upgrade, a restart is required.
If you select 'y' the system will be restarted.

Continue [yN] y

システム再起動しろやと出るので再起動する。
なんか途中で 15.10 とかプロンプト出たんだけど大丈夫かな、心配だなあ・・・・。
16.04 にしたかったんだけど・・・。
英語読み間違えたか?


➜  ~ ssh phy2
Welcome to Ubuntu 15.10 (GNU/Linux 4.2.0-35-generic x86_64)

 * Documentation:  https://help.ubuntu.com/

  System information as of Thu May  5 14:40:07 JST 2016

  System load:  1.76             Processes:           174
  Usage of /:   8.0% of 1.78TB   Users logged in:     0
  Memory usage: 5%               IP address for eth0: 172.16.216.2
  Swap usage:   0%               IP address for p7p1: 172.17.1.1

  Graph this data and manage this system at:
    https://landscape.canonical.com/

Last login: Thu May  5 13:22:30 2016
To run a command as administrator (user "root"), use "sudo ".
See "man sudo_root" for details.

あかん、、、

Normal なの確認してもう一発あげる。


wnoguchi@phy2:~$ sudo vim /etc/update-manager/release-upgrades
wnoguchi@phy2:~$ sudo do-release-upgrade

うまくいった。

Mac OS X のスクリーンショット保存場所&ファイル名を変更する

Mac に標準で実装されているスクリーンショットには 2 点不満があった。

  1. スクリーンショットがデスクトップに保存される。
  2. スクリーンショットが日本語名で保存される。

この 2 点を解消する。
標準でも iTerm2 でもいいのでターミナルを立ち上げてやります。

スクリーンショットがデスクトップに保存される

これは Dropbox とか ownCloud のフォルダに保存して欲しかったので真っ先に変えた。
そうすれば保存した瞬間にクラウドストレージ上に同期されるのでうれしい。

defaults write com.apple.screencapture location ~/Dropbox/
killall SystemUIServer

スクリーンショットが日本語名で保存される

これは別にいいかなと思っていたので、多分できると思いつつやってなかった。
最初はこんな名前で保存される。

スクリーンショット 2016-04-01 22.49.28.png

これがこうすると

defaults write com.apple.screencapture name "ScreenShot"
killall SystemUIServer

こうなる

ScreenShot 2016-05-05 14.19.30.png

スペースが挿入されるのが非常にキモかったので本来なら日付のフォーマットとかも変更したかったけど、結構深そうだったのでやめた。

Samba ファイルサーバーの構築 (CnetOS7.2)

認証無しで共有サーバーに書き込めるのがいいと思っていたけど、しゃべる NetBIOS のプロトコルのバージョンが下がって遅くなるんだよね。
なので pdbedit で認証されているユーザじゃないと書き込めないようになっています。
ちなみに Samba のバージョンは 4 系なので Active Directory ドメインコントローラとして動作させようと思えば構築できる。

[root@phy3 samba]# yum info samba
(snip)
名前                : samba
アーキテクチャー    : x86_64
バージョン          : 4.2.10
リリース            : 6.el7_2
容量                : 1.8 M
リポジトリー        : installed
提供元リポジトリー  : updates
要約                : Server and Client software to interoperate with Windows machines
URL                 : http://www.samba.org/
ライセンス          : GPLv3+ and LGPLv3+
説明                : Samba is the standard Windows interoperability suite of programs for Linux and Unix.

Samba のインストール

sudo yum -y install samba
sudo mkdir /var/samba

自分の共有フォルダを作成

mkdir ~/samba

既存のユーザを追加

こいつで認証を通す。

sudo pdbedit -a wnoguchi
new password:
retype new password:
Unix username:        wnoguchi
NT username:
Account Flags:        [U          ]
User SID:             S-1-5-21-3726826207-3823386518-2277225043-1000
Primary Group SID:    S-1-5-21-3726826207-3823386518-2277225043-513
Full Name:            Wataru Noguchi
Home Directory:       \\phy3\wnoguchi
HomeDir Drive:
Logon Script:
Profile Path:         \\phy3\wnoguchi\profile
Domain:               PHY3
Account desc:
Workstations:
Munged dial:
Logon time:           0
Logoff time:          木, 07  2月 2036 00:06:39 JST
Kickoff time:         木, 07  2月 2036 00:06:39 JST
Password last set:    水, 04  5月 2016 10:11:26 JST
Password can change:  水, 04  5月 2016 10:11:26 JST
Password must change: never
Last bad password   : 0
Bad password count  : 0
Logon hours         : FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

共有フォルダの所有者変更

自分しか使わないけどね。。。

sudo chown nobody:nobody /var/samba

Samba の設定

  • 設定ファイルバックアップ
sudo cp -rp /etc/samba{,.orig}
  • /etc/samba/smb.conf
[global]
unix charset = UTF-8
dos charset = CP932

workgroup = MYGROUP
↓
workgroup = PG1X

アクセス許可設定

;    hosts allow = 127. 192.168.12. 192.168.13.
↓
    hosts allow = 127. 172.16. 172.17. 172.18.

プリンタ使わない
    load printers = yes
    disable spoolss = yes

[homes]
    comment = Home Directories
    path = %H/samba

    vfs objects = recycle
    recycle:repository = .recycle
    recycle:keeptree = no
    recycle:versions = yes
    recycle:touch = no
    recycle:maxsize = 0
    recycle:exclude = *.tmp ~$*

[public]
    comment = Public Stuff
    path = /var/samba
    public = yes
    writable = yes
    only guest = yes
    vfs objects = recycle
    recycle:repository = .recycle
    recycle:keeptree = no
    recycle:versions = yes
    recycle:touch = no
    recycle:maxsize = 0
    recycle:exclude = *.tmp ~$*

smb, nmb 起動

sudo systemctl start smb
sudo systemctl start nmb
sudo systemctl enable smb
sudo systemctl enable nmb

ごみ箱を定期的に空にするスクリプトを作成

1ヶ月間 = 30 日 = 30 * 24 時間 = 720 時間 アクセスのないものは完全に削除する

sudo cat <<'EOF' >/etc/cron.weekly/recyclewatch
#!/bin/bash
for user in `ls /home/`
do
  if [ -d /home/$user/.recycle ]; then
    tmpwatch -f 720 /home/$user/.recycle/
  fi
done
if [ -d /var/samba/.recycle ]; then
  tmpwatch -f 720 /var/samba/.recycle/
fi
EOF
sudo chmod 744 /etc/cron.weekly/recyclewatch

ファイアウォールの穴を開ける

sudo firewall-cmd --permanent --zone=public --add-service=samba
sudo firewall-cmd --reload

接続の仕方

認証聞かれます。

Windows の場合

\\72.16.216.3
\\72.16.216.3\public\

Mac, Linux の場合

smb://172.16.216.3/
smb://172.16.216.3/public/

トラブルシューティング

認証は通るみたいだが接続はできない。

[root@phy3 samba]# tailf /var/log/samba/log.macbookair-d7e0
[2016/05/04 11:00:01.995083,  0] ../source3/smbd/service.c:798(make_connection_snum)
  canonicalize_connect_path failed for service public, path /home/samba
[2016/05/04 11:00:01.997818,  0] ../source3/smbd/service.c:798(make_connection_snum)
  canonicalize_connect_path failed for service public, path /home/samba
[2016/05/04 11:01:04.905785,  0] ../source3/smbd/service.c:798(make_connection_snum)
  canonicalize_connect_path failed for service public, path /home/samba

Oops… 書き間違い。
そもそも存在しないディレクトリを指定していたりするとこんなエラーになる。
修正する。

[public]
    comment = Public Stuff
    path = /home/samba
↓
[public]
    comment = Public Stuff
    path = /var/samba

そしてリスタート。

sudo systemctl restart smb
sudo systemctl restart nmb

参考サイト

  1. Windowsファイルサーバー構築(Samba) – CentOSで自宅サーバー構築
  2. CentOS7にSambaをインストール | 俺的備忘録 〜なんかいろいろ〜

Cisco Catalyst 3750v2, 2960 で作る L3 スイッチでの VLAN 間ルーティング

Router on a Stick 構成ではなく、 L3 スイッチで VLAN 間ルーティングを行う場合の設定。
ASW 2 台と L3 スイッチ 1 台で構成する。
IOS のバージョンはすべて 15 系。
VLAN 間の通信の制限とかは ACL でやるのかな。

ASW1

ASW1(config)#vlan 10,20
ASW1(config-vlan)#exit
ASW1(config)#int range
*Mar  1 06:54:34.872: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
ASW1(config)#int range
*Mar  1 06:54:35.871: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to down
ASW1(config)#int range
*Mar  1 06:54:38.270: %LINK-3-UPDOWN: Interface FastEthernet0/8, changed state to up
ASW1(config)#int range
*Mar  1 06:54:38.354: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
*Mar  1 06:54:39.276: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to up
ASW1(config)#int range
*Mar  1 06:54:39.352: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to down
*Mar  1 06:54:40.753: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down
ASW1(config)#int range
*Mar  1 06:54:40.996: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Mar  1 06:54:41.751: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to down
*Mar  1 06:54:42.003: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
ASW1(config)#int range
*Mar  1 06:54:45.073: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
ASW1(config)#int range
*Mar  1 06:54:45.350: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up
ASW1(config)#int range
*Mar  1 06:54:46.071: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down
*Mar  1 06:54:46.356: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
ASW1(config)#int range
*Mar  1 06:54:47.069: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to down
ASW1(config)#int range
*Mar  1 06:54:51.389: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
*Mar  1 06:54:52.396: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
ASW1(config)#int range
*Mar  1 06:55:06.296: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
ASW1(config)#int range fa 0/1-3
ASW1(config-if-range)#swi
ASW1(config-if-range)#switchport mod
ASW1(config-if-range)#switchport mode ac
ASW1(config-if-range)#switchport mode access
ASW1(config-if-range)#exit
ASW1(config)#int fa 0/2
ASW1(config-if)#swi
ASW1(config-if)#switchport a
ASW1(config-if)#switchport ac
ASW1(config-if)#switchport access vl
ASW1(config-if)#switchport access vlan 10
ASW1(config-if)#int fa 0/3
ASW1(config-if)#swi
ASW1(config-if)#switchport ac
ASW1(config-if)#switchport access vl
ASW1(config-if)#switchport access vlan 20
ASW1(config-if)#int fa 0/8
ASW1(config-if)#swi
ASW1(config-if)#switchport mo
ASW1(config-if)#switchport mode tru
ASW1(config-if)#switchport mode trunk
ASW1(config-if)#
*Mar  1 07:07:04.730: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to down
ASW1(config-if)#
*Mar  1 07:07:07.750: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to up
ASW1(config-if)#swi
ASW1(config-if)#switchport tru
ASW1(config-if)#switchport trunk na
ASW1(config-if)#switchport trunk native v
ASW1(config-if)#switchport trunk native vlan 99
ASW1(config-if)#swi
ASW1(config-if)#switchport
*Mar  1 07:07:30.508: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 1 on FastEthernet0/8 VLAN99.
*Mar  1 07:07:30.508: %SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet0/8 on VLAN0001. Inconsistent peer vlan.
*Mar  1 07:07:30.508: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/8 on VLAN0099. Inconsistent local vlan.
ASW1(config-if)#switchport none
ASW1(config-if)#switchport nonegotiate
ASW1(config-if)#
*Mar  1 07:08:15.815: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
ASW1(config-if)#exit
ASW1(config)#int vlan 1
ASW1(config-if)#ip add
ASW1(config-if)#ip address 172.17.1.100
*Mar  1 07:09:15.819: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
ASW1(config-if)#ip address 172.17.1.100 255.255.255.0
ASW1(config-if)#no shut
ASW1(config-if)#
*Mar  1 07:10:15.822: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
ASW1(config-if)#exit
ASW1(config)#ip defa
ASW1(config)#ip default-gateway 172.17.1.254 255.255.255.0
                                             ^
% Invalid input detected at '^' marker.

ASW1(config)#ip default-gateway 172.17.1.254
ASW1(config)#exit
*Mar  1 07:11:15.826: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
ASW1(config)#exit
ASW1#
*Mar  1 07:11:18.620: %SYS-5-CONFIG_I: Configured from console by console
ASW1#
*Mar  1 07:12:15.830: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
ASW1#
*Mar  1 07:12:20.184: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/8 on VLAN0001. Port consistency restored.
*Mar  1 07:12:20.184: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/8 on VLAN0099. Port consistency restored.
ASW1#
*Mar  1 07:13:04.626: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
ASW1#
*Mar  1 07:13:05.658: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 1 on FastEthernet0/8 VLAN99.
*Mar  1 07:13:05.658: %SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet0/8 on VLAN0001. Inconsistent peer vlan.
*Mar  1 07:13:05.658: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/8 on VLAN0099. Inconsistent local vlan.
ASW1#
*Mar  1 07:13:13.560: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
*Mar  1 07:13:14.567: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
ASW1#
*Mar  1 07:13:15.574: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
ASW1#
*Mar  1 07:13:16.580: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
ASW1#
*Mar  1 07:13:17.587: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
ASW1#
*Mar  1 07:13:18.593: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
ASW1#
*Mar  1 07:13:19.600: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
ASW1#
*Mar  1 07:13:20.607: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
ASW1#
*Mar  1 07:14:08.808: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/8 on VLAN0001. Port consistency restored.
*Mar  1 07:14:08.808: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/8 on VLAN0099. Port consistency restored.

ASW2

ASW2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
ASW2(config)#vlan 10,20
ASW2(config-vlan)#exit
ASW2(config)#
*Mar  1 06:54:50.819: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
ASW2(config)#
*Mar  1 06:54:51.817: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to down
ASW2(config)#
*Mar  1 06:54:54.703: %LINK-3-UPDOWN: Interface FastEthernet0/8, changed state to up
*Mar  1 06:54:55.710: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to up
ASW2(config)#
*Mar  1 06:54:58.184: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
ASW2(config)#
*Mar  1 06:54:59.183: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to down
ASW2(config)#
*Mar  1 06:55:00.105: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down
ASW2(config)#
*Mar  1 06:55:00.818: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Mar  1 06:55:01.103: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to down
ASW2(config)#
*Mar  1 06:55:01.707: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
*Mar  1 06:55:01.825: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
*Mar  1 06:55:02.706: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down
ASW2(config)#
*Mar  1 06:55:02.739: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up
*Mar  1 06:55:03.704: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to down
*Mar  1 06:55:03.746: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
ASW2(config)#
*Mar  1 06:55:05.180: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
*Mar  1 06:55:06.187: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
ASW2(config)#
*Mar  1 06:55:22.729: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
ASW2(config)#int range fa 0/1-3
ASW2(config-if-range)#switchport mode access
ASW2(config-if-range)#exit
ASW2(config)#int fa 0/2
ASW2(config-if)#swi
ASW2(config-if)#switchport ac
ASW2(config-if)#switchport access vl
ASW2(config-if)#switchport access vlan 10
ASW2(config-if)#int fa 0/3
ASW2(config-if)#swi
ASW2(config-if)#switchport a
ASW2(config-if)#switchport ac
ASW2(config-if)#switchport access v
ASW2(config-if)#switchport access vlan 2
ASW2(config-if)#switchport access vlan 20
ASW2(config-if)#int fa 0/8
ASW2(config-if)#swi
ASW2(config-if)#switchport mo
ASW2(config-if)#switchport mode tru
ASW2(config-if)#switchport mode trunk
ASW2(config-if)#
*Mar  1 07:07:12.498: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to down
ASW2(config-if)#
*Mar  1 07:07:15.518: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to up
ASW2(config-if)#switchport trunk native vlan 99
ASW2(config-if)#
*Mar  1 07:07:46.598: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 1 on FastEthernet0/8 VLAN99.
*Mar  1 07:07:46.598: %SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet0/8 on VLAN0001. Inconsistent peer vlan.
*Mar  1 07:07:46.598: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/8 on VLAN0099. Inconsistent local vlan.
ASW2(config-if)#switchport nonegotiate
ASW2(config-if)#
*Mar  1 07:08:23.583: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
ASW2(config-if)#exit
ASW2(config)#
*Mar  1 07:09:23.595: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
ASW2(config)#int vlan 1
ASW2(config-if)#ip address 172.17.1.101 255.255.255.0
ASW2(config-if)#no shut
ASW2(config-if)#exit
ASW2(config)#
*Mar  1 07:10:23.599: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
ASW2(config)#ip default-gateway 172.17.1.254
ASW2(config)#exit
ASW2#
*Mar  1 07:11:22.042: %SYS-5-CONFIG_I: Configured from console by console
ASW2#
*Mar  1 07:11:23.602: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
ASW2#
*Mar  1 07:12:23.598: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
ASW2#
*Mar  1 07:12:58.738: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/8 on VLAN0001. Port consistency restored.
*Mar  1 07:12:58.738: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/8 on VLAN0099. Port consistency restored.
ASW2#
*Mar  1 07:13:04.719: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
ASW2#
*Mar  1 07:13:05.725: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 1 on FastEthernet0/8 VLAN99.
*Mar  1 07:13:05.725: %SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet0/8 on VLAN0001. Inconsistent peer vlan.
*Mar  1 07:13:05.725: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/8 on VLAN0099. Inconsistent local vlan.
ASW2#
*Mar  1 07:13:13.636: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
*Mar  1 07:13:14.642: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
ASW2#
*Mar  1 07:13:15.649: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
ASW2#
*Mar  1 07:13:16.656: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
ASW2#
*Mar  1 07:13:17.662: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
*Mar  1 07:13:18.669: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
ASW2#
*Mar  1 07:13:19.676: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
ASW2#
*Mar  1 07:13:20.682: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
ASW2#
*Mar  1 07:14:08.875: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/8 on VLAN0001. Port consistency restored.
*Mar  1 07:14:08.875: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/8 on VLAN0099. Port consistency restored.
ASW2#
*Mar  1 07:19:48.739: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down
*Mar  1 07:19:49.746: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to down
ASW2#
*Mar  1 07:19:52.019: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
*Mar  1 07:19:53.026: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up

DSW

DSW(config)#vlan 10,20,99
DSW(config-vlan)#exit
DSW(config)#int
*Mar  1 07:11:31.966: %SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet1/0/1 VLAN1.
*Mar  1 07:11:31.966: %SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet1/0/1 on VLAN0001. Inconsistent port type.
DSW(config)#int range fa 0/1-2
                           ^
% Invalid input detected at '^' marker.

DSW(config)#int range fa 10/1-2
*Mar  1 07:11:48.114: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet1/0/2 (1), with ASW2 FastEthernet0/8 (99).
DSW(config)#int range fa 1/0/1-2
DSW(config-if-range)#swi
DSW(config-if-range)#switchport tr
DSW(config-if-range)#switchport trunk enca
DSW(config-if-range)#switchport trunk encapsulation do
DSW(config-if-range)#switchport trunk encapsulation dot1q
DSW(config-if-range)#
*Mar  1 07:12:09.840: %SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet1/0/2 VLAN1.
*Mar  1 07:12:09.840: %SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet1/0/2 on VLAN0001. Inconsistent port type.
DSW(config-if-range)#swi
DSW(config-if-range)#switchport mo
DSW(config-if-range)#switchport mode tr
DSW(config-if-range)#switchport mode trunk
DSW(config-if-range)#
*Mar  1 07:12:26.190: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1, changed state to down
*Mar  1 07:12:26.198: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/2, changed state to down
DSW(config-if-range)#
*Mar  1 07:12:29.218: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1, changed state to up
*Mar  1 07:12:29.243: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/2, changed state to up
DSW(config-if-range)#
*Mar  1 07:12:29.898: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 99 on FastEthernet1/0/2 VLAN1.
*Mar  1 07:12:29.898: %SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet1/0/2 on VLAN0099. Inconsistent peer vlan.
*Mar  1 07:12:29.898: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet1/0/2 on VLAN0001. Inconsistent local vlan.
*Mar  1 07:12:30.107: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 99 on FastEthernet1/0/1 VLAN1.
*Mar  1 07:12:30.107: %
DSW(config-if-range)#SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet1/0/1 on VLAN0099. Inconsistent peer vlan.
*Mar  1 07:12:30.107: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet1/0/1 on VLAN0001. Inconsistent local vlan.
DSW(config-if-range)#
*Mar  1 07:12:40.417: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet1/0/1 (1), with ASW1 FastEthernet0/8 (99).
DSW(config-if-range)#s
*Mar  1 07:12:48.118: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet1/0/2 (1), with ASW2 FastEthernet0/8 (99).
DSW(config-if-range)#swi
DSW(config-if-range)#switchport tru
DSW(config-if-range)#switchport trunk na
DSW(config-if-range)#switchport trunk native 99
                                               ^
% Invalid input detected at '^' marker.

DSW(config-if-range)#switchport trunk native ?
  vlan  Set native VLAN when interface is in trunking mode

DSW(config-if-range)#switchport trunk native v
DSW(config-if-range)#switchport trunk native vlan 9
DSW(config-if-range)#switchport trunk native vlan 99
DSW(config-if-range)#swi
DSW(config-if-range)#switchport none
DSW(config-if-range)#switchport nonegotiate
DSW(config-if-range)#exit
DSW(config)#ip ro
DSW(config)#ip rout
*Mar  1 07:13:33.039: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet1/0/2 on VLAN0099. Port consistency restored.
*Mar  1 07:13:33.039: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet1/0/2 on VLAN0001. Port consistency restored.
*Mar  1 07:13:33.232: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet1/0/1 on VLAN0099. Port consistency restored.
*Mar  1 07:13:33.232: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet1/0/1 on VLAN0001. Port consistency restored.
DSW(config)#ip routi
DSW(config)#ip routing
*Mar  1 07:14:03.061: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
DSW(config)#ip routing
DSW(config)#int vlan 1
DSW(config-if)#ip add
DSW(config-if)#ip address 172.17.1.254 255.255.255.0
DSW(config-if)#no shut
DSW(config-if)#int vlan 10
DSW(config-if)#
*Mar  1 07:17:13.458: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
DSW(config-if)#ip address 172.17.10.254 255.255.255.0
DSW(config-if)#no shut
DSW(config-if)#int vlan 20
DSW(config-if)#
*Mar  1 07:17:28.524: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
DSW(config-if)#ip address 172.17.20.254 255.255.255.0
DSW(config-if)#no shut
DSW(config-if)#end
DSW#
*Mar  1 07:17:52.985: %SYS-5-CONFIG_I: Configured from console by console

ルーティングテーブルの確認。

DSW#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.17.0.0/16 is variably subnetted, 6 subnets, 2 masks
C        172.17.1.0/24 is directly connected, Vlan1
L        172.17.1.254/32 is directly connected, Vlan1
C        172.17.10.0/24 is directly connected, Vlan10
L        172.17.10.254/32 is directly connected, Vlan10
C        172.17.20.0/24 is directly connected, Vlan20
L        172.17.20.254/32 is directly connected, Vlan20

MariaDB 10.1 を CentOS 7.2 にインストールする

/etc/yum.repos.d/MariaDB.repo を作成する。

# MariaDB 10.1 CentOS repository list - created 2016-05-01 03:05 UTC
# http://mariadb.org/mariadb/repositories/
[mariadb]
name = MariaDB
baseurl = http://yum.mariadb.org/10.1/centos7-amd64
gpgkey=https://yum.mariadb.org/RPM-GPG-KEY-MariaDB
gpgcheck=1
sudo yum -y install MariaDB-server MariaDB-client
sudo systemctl enable mariadb
sudo systemctl start mariadb
[root@localhost ~]# systemctl status mariadb
● mariadb.service - MariaDB database server
   Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled)
  Drop-In: /etc/systemd/system/mariadb.service.d
           └─migrated-from-my.cnf-settings.conf
   Active: active (running) since 日 2016-05-01 03:14:18 UTC; 11s ago
 Main PID: 3783 (mysqld)
   Status: "Taking your SQL requests now..."
   CGroup: /system.slice/mariadb.service
           └─3783 /usr/sbin/mysqld

 5月 01 03:14:18 localhost.localdomain mysqld[3783]: 2016-05-01  3:14:18 140...
 5月 01 03:14:18 localhost.localdomain mysqld[3783]: 2016-05-01  3:14:18 140...
 5月 01 03:14:18 localhost.localdomain mysqld[3783]: 2016-05-01  3:14:18 140...
 5月 01 03:14:18 localhost.localdomain mysqld[3783]: 2016-05-01  3:14:18 140...
 5月 01 03:14:18 localhost.localdomain mysqld[3783]: 2016-05-01  3:14:18 140...
 5月 01 03:14:18 localhost.localdomain mysqld[3783]: 2016-05-01  3:14:18 140...
 5月 01 03:14:18 localhost.localdomain mysqld[3783]: 2016-05-01  3:14:18 140...
 5月 01 03:14:18 localhost.localdomain mysqld[3783]: 2016-05-01  3:14:18 140...
 5月 01 03:14:18 localhost.localdomain mysqld[3783]: Version: '10.1.13-Maria...
 5月 01 03:14:18 localhost.localdomain systemd[1]: Started MariaDB database ...
Hint: Some lines were ellipsized, use -l to show in full.
[root@localhost ~]# mysql -u root
Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 2
Server version: 10.1.13-MariaDB MariaDB Server

Copyright (c) 2000, 2016, Oracle, MariaDB Corporation Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]> exit
Bye