[12/29] Ubuntu 17.10 (Artful Aardvark) Git LFS パッケージリポジトリがみつからないってゆってる

Pocket

年末にこんなことをやっているのがそもそも良くないのかもしれない。

wnoguchi@serial:~$ sudo apt -y update && sudo apt -y upgrade --auto-remove && sudo systemctl reboot
取得:1 http://security.ubuntu.com/ubuntu artful-security InRelease [78.6 kB]
ヒット:2 http://ppa.launchpad.net/git-core/ppa/ubuntu artful InRelease
無視:3 https://packagecloud.io/github/git-lfs/ubuntu artful InRelease
取得:4 http://security.ubuntu.com/ubuntu artful-security/main amd64 DEP-11 Metadata [204 B]
取得:5 http://security.ubuntu.com/ubuntu artful-security/universe amd64 DEP-11 Metadata [10.2 kB]
エラー:6 https://packagecloud.io/github/git-lfs/ubuntu artful Release
  404  Not Found
ヒット:7 http://jp.archive.ubuntu.com/ubuntu artful InRelease
取得:8 http://jp.archive.ubuntu.com/ubuntu artful-updates InRelease [78.6 kB]
取得:9 http://jp.archive.ubuntu.com/ubuntu artful-backports InRelease [72.2 kB]
取得:10 http://jp.archive.ubuntu.com/ubuntu artful-updates/main amd64 DEP-11 Metadata [56.6 kB]
取得:11 http://jp.archive.ubuntu.com/ubuntu artful-updates/main DEP-11 64x64 Icons [35.2 kB]
取得:12 http://jp.archive.ubuntu.com/ubuntu artful-updates/universe amd64 DEP-11 Metadata [48.3 kB]
取得:13 http://jp.archive.ubuntu.com/ubuntu artful-updates/universe DEP-11 64x64 Icons [48.4 kB]
パッケージリストを読み込んでいます... 完了
E: リポジトリ https://packagecloud.io/github/git-lfs/ubuntu artful Release には Release ファイルがありません。
N: このようなリポジトリから更新を安全に行うことができないので、デフォルトでは更新が無効になっています。
N: リポジトリの作成とユーザ設定の詳細は、apt-secure(8) man ページを参照してください。
wnoguchi@serial:~$ git lfs
git-lfs/2.2.1 (GitHub; linux amd64; go 1.8.1)
Sorry, no usage text found for "git-lfs"

17.10 (Artful Aardvark) なんだけど 404 になってる。
圧倒的な Rails の 404 。

先日 Git LFS 入れたときはそんなことなかったんだけどな。

  1. Missing apt repository for Ubuntu 17.10 Artful · Issue #2702 · git-lfs/git-lfs

同じようなのが 10 月に issue あがっているがどうなんだ。
似たような issue ないか最近探してみたけどない。

俺がインストールした Git LFS は幻だったのか?と思ってヒストリ辿ってみたらインストールした形跡あった。

wnoguchi@serial:~$ curl -s https://packagecloud.io/install/repositories/github/git-lfs/script.deb.sh | sudo bash
Detected operating system as Ubuntu/artful.
Checking for curl...
Detected curl...
Checking for gpg...
Detected gpg...
Running apt-get update... done.
Installing apt-transport-https... done.
Installing /etc/apt/sources.list.d/github_git-lfs.list...done.
Importing packagecloud gpg key... done.
Running apt-get update... done.

The repository is setup! You can now install packages.
wnoguchi@serial:~$ ./updater.sh
ヒット:1 http://jp.archive.ubuntu.com/ubuntu artful InRelease
ヒット:2 http://jp.archive.ubuntu.com/ubuntu artful-updates InRelease
ヒット:3 http://jp.archive.ubuntu.com/ubuntu artful-backports InRelease
ヒット:4 http://security.ubuntu.com/ubuntu artful-security InRelease
ヒット:5 http://ppa.launchpad.net/git-core/ppa/ubuntu artful InRelease
無視:6 https://packagecloud.io/github/git-lfs/ubuntu artful InRelease
エラー:7 https://packagecloud.io/github/git-lfs/ubuntu artful Release
  404  Not Found
パッケージリストを読み込んでいます... 完了
E: リポジトリ https://packagecloud.io/github/git-lfs/ubuntu artful Release には Release ファイルがありません。
N: このようなリポジトリから更新を安全に行うことができないので、デフォルトでは更新が無効になっています。
N: リポジトリの作成とユーザ設定の詳細は、apt-secure(8) man ページを参照してください。
  1. Installation · git-lfs/git-lfs Wiki
  2. apt-get updateでエラーが出た(Ubuntu) | Hornet|静岡拠点のWeb、ホームページ制作

とりあえず更新できないのは困るので git lfs はコメントアウトするとかして除外する。

sudo vim /etc/apt/sources.list

見つからねえ

こういうのは *.d ディレクトリがあるって相場が決まってる。

これだ

sudo vim /etc/apt/sources.list.d/github_git-lfs.list

deb https://packagecloud.io/github/git-lfs/ubuntu/ artful main
deb-src https://packagecloud.io/github/git-lfs/ubuntu/ artful main
↓
#deb https://packagecloud.io/github/git-lfs/ubuntu/ artful main
#deb-src https://packagecloud.io/github/git-lfs/ubuntu/ artful main

とりあえず除外してうまくいった。

wnoguchi@serial:~$ sudo apt -y update && sudo apt -y upgrade --auto-remove && sudo systemctl reboot
ヒット:1 http://jp.archive.ubuntu.com/ubuntu artful InRelease
ヒット:2 http://jp.archive.ubuntu.com/ubuntu artful-updates InRelease
ヒット:3 http://jp.archive.ubuntu.com/ubuntu artful-backports InRelease
ヒット:4 http://security.ubuntu.com/ubuntu artful-security InRelease
ヒット:5 http://ppa.launchpad.net/git-core/ppa/ubuntu artful InRelease
無視:6 https://packagecloud.io/github/git-lfs/ubuntu artful InRelease
エラー:7 https://packagecloud.io/github/git-lfs/ubuntu artful Release
  404  Not Found
パッケージリストを読み込んでいます... 完了
アップグレードできるパッケージが 5 個あります。表示するには 'apt list --upgradable' を実行してください。
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
アップグレードパッケージを検出しています... 完了
以下のパッケージが新たにインストールされます:
  libpcre2-8-0
以下のパッケージはアップグレードされます:
  firefox firefox-locale-en firefox-locale-ja git git-man
アップグレード: 5 個、新規インストール: 1 個、削除: 0 個、保留: 0 個。
51.6 MB のアーカイブを取得する必要があります。
この操作後に追加で 4,865 kB のディスク容量が消費されます。
取得:1 http://jp.archive.ubuntu.com/ubuntu artful/universe amd64 libpcre2-8-0 amd64 10.22-3 [165 kB]
取得:2 http://jp.archive.ubuntu.com/ubuntu artful-updates/main amd64 firefox amd64 57.0.3+build1-0ubuntu0.17.10.1 [44.1 MB]
取得:3 http://ppa.launchpad.net/git-core/ppa/ubuntu artful/main amd64 git amd64 1:2.15.1-1~ppa0~ubuntu17.10.1 [4,570 kB]
取得:4 http://jp.archive.ubuntu.com/ubuntu artful-updates/main amd64 firefox-locale-en amd64 57.0.3+build1-0ubuntu0.17.10.1 [692 kB]
取得:5 http://jp.archive.ubuntu.com/ubuntu artful-updates/main amd64 firefox-locale-ja amd64 57.0.3+build1-0ubuntu0.17.10.1 [482 kB]
取得:6 http://ppa.launchpad.net/git-core/ppa/ubuntu artful/main amd64 git-man all 1:2.15.1-1~ppa0~ubuntu17.10.1 [1,514 kB]
51.6 MB を 22秒 で取得しました (2,280 kB/s)
(データベースを読み込んでいます ... 現在 173754 個のファイルとディレクトリがインストールされています。)
.../0-git_1%3a2.15.1-1~ppa0~ubuntu17.10.1_amd64.deb を展開する準備をしています ...
git (1:2.15.1-1~ppa0~ubuntu17.10.1) で (1:2.14.1-1ubuntu4 に) 上書き展開しています ...
.../1-git-man_1%3a2.15.1-1~ppa0~ubuntu17.10.1_all.deb を展開する準備をしています ...
git-man (1:2.15.1-1~ppa0~ubuntu17.10.1) で (1:2.14.1-1ubuntu4 に) 上書き展開しています ...
以前に未選択のパッケージ libpcre2-8-0:amd64 を選択しています。
.../2-libpcre2-8-0_10.22-3_amd64.deb を展開する準備をしています ...
libpcre2-8-0:amd64 (10.22-3) を展開しています...
.../3-firefox_57.0.3+build1-0ubuntu0.17.10.1_amd64.deb を展開する準備をしています ...
firefox (57.0.3+build1-0ubuntu0.17.10.1) で (57.0.1+build2-0ubuntu0.17.10.1 に) 上書き展開しています ...
.../4-firefox-locale-en_57.0.3+build1-0ubuntu0.17.10.1_amd64.deb を展開する準備をしています ...
firefox-locale-en (57.0.3+build1-0ubuntu0.17.10.1) で (57.0.1+build2-0ubuntu0.17.10.1 に) 上書き展開しています ...
.../5-firefox-locale-ja_57.0.3+build1-0ubuntu0.17.10.1_amd64.deb を展開する準備をしています ...
firefox-locale-ja (57.0.3+build1-0ubuntu0.17.10.1) で (57.0.1+build2-0ubuntu0.17.10.1 に) 上書き展開しています ...
git-man (1:2.15.1-1~ppa0~ubuntu17.10.1) を設定しています ...
firefox-locale-ja (57.0.3+build1-0ubuntu0.17.10.1) を設定しています ...
firefox-locale-en (57.0.3+build1-0ubuntu0.17.10.1) を設定しています ...
mime-support (3.60ubuntu1) のトリガを処理しています ...
desktop-file-utils (0.23-1ubuntu3) のトリガを処理しています ...
libc-bin (2.26-0ubuntu2) のトリガを処理しています ...
firefox (57.0.3+build1-0ubuntu0.17.10.1) を設定しています ...
Please restart all running instances of firefox, or you will experience problems.
man-db (2.7.6.1-2) のトリガを処理しています ...
gnome-menus (3.13.3-6ubuntu5) のトリガを処理しています ...
libpcre2-8-0:amd64 (10.22-3) を設定しています ...
hicolor-icon-theme (0.17-1) のトリガを処理しています ...
git (1:2.15.1-1~ppa0~ubuntu17.10.1) を設定しています ...
libc-bin (2.26-0ubuntu2) のトリガを処理しています ...

根本的に何かが解決したわけじゃないが、時間おいて見に行けばなんとかなるのではないだろうか。
LTS じゃないしこんなことは日常茶飯事だろう。

ここでブーブー文句垂れていても何も解決しないし世間様に何も貢献していない気がするのですこし考え直して GitHub の Issue 起こしておいた。

Ubuntu 17.10 artful repository not found. · Issue #2804 · git-lfs/git-lfs

Sponsored Link

Leave a Reply

Your email address will not be published. Required fields are marked *