平成29年秋 ネットワークスペシャリスト試験受験体験記

昨日は平成29年秋のネットワークスペシャリスト試験を受験してまいりました。
2年以上高度試験を受けていなかったので午前I免除なしで受けました。
丸一日拘束されるのはやっぱ疲れますね。。。
下記に私の中途半端な解答置いておくので、興味ある方はご覧ください。

テーマ

  1. 午前I (共通)
  2. 午前II NW用
  3. 午後I SSL-VPN, VDI導入でのトラフィック変化, クラウド事業者との VPN 接続と OSPF, BGP に関する知識を問う問題
  4. 午後II SDN, 無線LAN環境への移行

解答直リンク

  1. 午前I (共通) IPA 公式 https://www.jitec.ipa.go.jp/1_04hanni_sukiru/mondai_kaitou_2017h29_2/2017h29a_koudo_am1_ans.pdf
  2. 午前II NW用 IPA 公式 https://www.jitec.ipa.go.jp/1_04hanni_sukiru/mondai_kaitou_2017h29_2/2017h29a_nw_am2_ans.pdf
  3. 午後I iTEC 速報 https://www.itec.co.jp/wp-content/uploads/shiken/2017a/2017a_nw_pm1_kaito.pdf
  4. 午後II iTEC 速報 https://www.itec.co.jp/wp-content/uploads/shiken/2017a/2017a_nw_pm2_kaito.pdf

IPA の公式解答はこちら(午後はまだ)

所感

午前試験

午前試験は過去問対策やってればどちらも解ける問題が多めでした。
応用情報受かる人ならネットワーク部分だけ重点的に過去問復習すれば余裕で突破できると思いました。

午後試験

午後試験で選択した問題は明らかにわからないという内容ではなかったので、受かったらいいなあという気持ちです。
SDN は全然明るくない技術なのと物量的に解ける気がしない内容だったので選択しませんでした。

ネットワークのトポロジや設計のデザインパターンの概要がわかるので、具体的なコンフィグには落とし込めませんが、それなりに有意な試験内容だったと思います。

コラム

ちなみに電話の呼量を表すアーランという単位がありますが、電話網で言語として Erlang (ないし Elixir ) が使われているので、ネーミング的にそういうのが浸透してるのかなと思いました。
あと、一回提出して点数の変化のしようがないのに自己採点して一喜一憂する行為、なんなんですかね。

やっと試験から開放されました。

次は CCIE R&S とりたいです。

CCIE Routing and Switching Certification Planning Memo

私用のリンク集です。

CertificationPlan – Google スプレッドシート
Networking_Data_Sheets – Google スプレッドシート
CCIE_R&S_CertificationPlan – Google スプレッドシート

Blueprint

400-101 CCIE Routing and Switching – Cisco
Exam Topics – The Cisco Learning Network

PDF
https://learningcontent.cisco.com/cln_storage/text/cln/marketing/exam-topics/400-101-w-cciers-v51.pdf

学習方法情報収集

CCIEの学習方法
CCIE ( Cisco Certified Internetwork Expert ) R&S 勉強方法
11ヶ月でCCIEラボに合格する為の効果的な勉強方法
CCIE書籍レビュー:初めはこの本を買いましょう。理由3つ
CCNAからCCIE合格までの勉強時間、約1200時間でした
CCNAからCCIEラボ試験合格までの学習期間
CCIE R&S CCO (cisco.com) 公式ドキュメント

CCIE学習の流れ 1:基礎固め

Blueprint を確認する。

CCIE Routing and Switching – Cisco
400-101 CCIE Routing and Switching – Cisco
CCIE R&S 筆記試験の内容 – 29406 – The Cisco Learning Network
CCIE R&S ラボ試験 – 23061 – The Cisco Learning Network

5ch を確認する

Step1:CCNAイージス

CCNAイージス:CCNA(100-105J、200-105J、200-125J)Web教科書

Step2:CCNPイージス

CCNPイージス:CCNP SWITCH(300-115J)と ROUTE(300-101J)のWeb教科書

Step3:CCIE試験範囲( QoS )

◆ QoSをはじめから

QoS(Quality of Service)技術解説

◆ QoS – CatalystスイッチのQoS

Catalyst QoS 技術解説

◆ QoS技術の完全解説

QoS技術の完全解説

Step4:CCIE試験範囲( マルチキャスト )

◆ マルチキャストの基礎技術

マルチキャストの技術解説(基礎)

◆ マルチキャストの応用技術

マルチキャストの技術解説(応用)

◆ マルチキャストコンフィグレーション解説

マルチキャスト – Ciscoコンフィグ設定

◆ あわせてブログ記事の「 マルチキャストの完全解説」もご参考下さい。

マルチキャストの完全解説

Step5:CCIE試験範囲( MPLS )

◆ MPLSをはじめから(基礎解説)

MPLSとは

◆ MPLS – CCIE参考書 1

Amazon.co.jp: MPLS Fundamentals 電子書籍: Luc De Ghein: Kindleストア

◆ MPLS – CCIE参考書 2

Amazon.co.jp: MPLS Configuration on Cisco IOS Software (paperback) (Networking Technology): Umesh Lakshman, Lancy Lobo: 洋書
MPLS Configuration on Cisco IOS Software

※ MPLSをマスターしなければCCIEラボに合格できないので、洋書でしっかり学習を!

CCIE学習の流れ 2:筆記試験だけで出題される技術を学習

Step6:CCIE筆記試験の範囲( Integrated IS-IS )

◆ Integrated IS-ISの技術 – ラボ試験では範囲外

Integrated IS-IS | ネットワークエンジニアとして

Step7:CCIE筆記試験の範囲( NW仮想化技術 )

◆ NW仮想化の技術 – VRF以外はラボ試験では範囲外

NW仮想化技術 | ネットワークエンジニアとして

Step8:CCIE筆記試験の範囲( Cloud、SDN、IoT )

◆ Cloud、SDN、IoTの技術 – ラボ試験では範囲外

仮想化技術をはじめから

◆ こちらも参考

Cloud / SDN / IoT技術解説

CCIE学習の流れ 3:公式本を読む

Step1 ~ Step8まで学習していればとても読みやすくなっている

Step9:CCIE試験範囲( 全般 )

Amazon.co.jp: CCIE Routing and Switching v5.0 Official Cert Guide Library 電子書籍: Narbik Kocharians, Peter Paluch: Kindleストア

CCIE学習の流れ 4:ラボで役立つ実践的な学習

ここまで学習できれば、以下の学習方法をおこなう

Step10:ラボ試験を一発合格するためのオーソドックスな学習

■ CCIE対策の洋書の Cisco Press( CCIE参考書 )を熟読

お勧めのCCIE参考書

■ CCOの熟読、試験範囲のバージョンのマニュアルを熟読

CCIE R&S CCO (cisco.com) 公式ドキュメント

■ ワークブック(INE)で反復演習、実機での数多くの動作検証

CCIE Routing & Switching Training – INE
CCIE Routing & Switching Training Bundles – INE

Windows の GNS3 で Cisco ルーターの設定を初期化する

GNS3 上でトポロジを構成する際、誤ったコンフィグを投入してしまって、あまつさえ保存してしまったとします。
こういった場合設定を初期化したいのですが、 erase startup-config だけだとルーターのホスト名の設定やロギングの挙動の調整といった、
ルーター初回起動時に投入される便利なコンフィグが読み込まれません。
最低限ルーター名だけでも最初から投入してくれないとわかりにくくて大変です。
GNS3 のドキュメント探してみましたが相当するようなドキュメントが見つからなかったので結構苦労しました。

トポロジを構成するルーターが 1, 2 台ならプロジェクト作り直せばいいかで済むんですが、 5 台以上になってくると大変です。
トポロジを作るのに加えてインターフェイスのラベルの位置とか微調整しているので作り直しってなったら発狂したくなります。

つーか、 Mac 版だと コンフィグ消したら NVRAM が勝手に初期化されたから、 Windows 版のバグのような気がしないでもない。

R1#erase startup-config
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: complete
R1#
*Mar  1 00:00:26.751: %SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram

誰か教えて下しあ。。。
GNS3 のドキュメントに載ってるのかな。。
今度腰を据えて GNS3 のドキュメント読もうかな。
というか GNS3 2.0 RC2 までいったようで、熱いね。
もうリリース間近といった感じ。

Releases · GNS3/gns3-gui

以下は Windows 版でのみの話し

ルーター上で

erase startup-config

これでルーターを再起動しても初回起動時に投入されるコンフィグは入らない。
ホスト名も設定されていない完全にまっさらに初期化されたルーターが起動される。
まあ、物理的なルーターの動作としてはこれが正しいんだが、コンセプトを理解したい場合は違う、そうじゃないとなる。

次に、ルーターを停止させる。これ重要。

右クリックでコンフィグをインポートする。

Windows なら

C:\Users\wnoguchi\GNS3\configs\ios_base_startup-config.txt

Mac なら

/Users/wnoguchi/GNS3/configs/ios_base_startup-config.txt

Linux なら(エスパーしている)

/home/GNS3/configs/ios_base_startup-config.txt

ちなみにコンフィグは以下のような感じになっていた。

!
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname %h
!
ip cef
no ip domain-lookup
no ip icmp rate-limit unreachable
ip tcp synwait 5
no cdp log mismatch duplex
!
line con 0
 exec-timeout 0 0
 logging synchronous
 privilege level 15
 no login
line aux 0
 exec-timeout 0 0
 logging synchronous
 privilege level 15
 no login
!
!
end

%h の部分がホスト名に置換されているわけですな。

プライベートコンフィグは読み込まなくて良い。

そしてルーター起動。

これで OK 。

OSPF 認証 インターフェイス認証

  1. 対応ページ: pp.222-225
  2. 対応試験: CCNPv2.0 Routing and Switching 300-101J ROUTE
  3. カテゴリ: OSPF
  4. サブカテゴリ: OSPF 認証 インターフェイス認証
  5. IOS: c3725-adventerprisek9-mz.124-15.T14.bin

OSPF認証について

OSPF認証タイプ

  • タイプ0 Null 認証
  • タイプ1 シンプルパスワード認証
  • タイプ2 MD5 認証

ネイバー認証の設定対象

  • インターフェイス
  • エリア
  • 仮想リンク

トポロジ

GNS3 プロジェクトファイルダウンロード

OSPF 認証設定前までやってあります。

GNS3 1.5.x では Windows, Mac 間の portable project のエクスポート、インポートがうまくいかない | | wnoguchi’s diary

Windows

ospf-authentication-interface

Mac

TODO

基本設定

R1

conf t
int f0/0
ip addr 10.0.12.1 255.255.255.0
no shut
!
! OSPF configuration
router ospf 1
router-id 1.1.1.1
network 10.0.0.0 0.255.255.255 area 0
end
wr

R2(ABR)

conf t
int f0/0
ip addr 10.0.12.2 255.255.255.0
no shut
int s0/0
ip addr 10.1.23.2 255.255.255.0
no shut
!
! OSPF configuration
router ospf 1
router-id 2.2.2.2
network 10.0.0.0 0.0.255.255 area 0
network 10.1.0.0 0.0.255.255 area 1
end
wr

R3

conf t
int s0/0
ip addr 10.1.23.3 255.255.255.0
no shut
!
! OSPF configuration
router ospf 1
router-id 3.3.3.3
network 10.0.0.0 0.255.255.255 area 1
end
wr

VPCs

なし

設定前の動作確認

なし

設定

R1

conf t
int f0/0
ip ospf authentication
ip ospf authentication-key CISCO

R2(ABR)

conf t
int f0/0
ip ospf authentication
ip ospf authentication-key CISCO
int s0/0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 ROUTE

R3

conf t
int s0/0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 ROUTE

検証

インターフェイスで認証が有効になっていることを確認する。

シンプルパスワード認証

R2#sh ip ospf int f0/0
FastEthernet0/0 is up, line protocol is up
  Internet Address 10.0.12.2/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 10.0.12.2
  Backup Designated router (ID) 1.1.1.1, Interface address 10.0.12.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 2
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 1.1.1.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
  Simple password authentication enabled

MD5 認証

R2#sh ip ospf int f0/0
FastEthernet0/0 is up, line protocol is up
  Internet Address 10.0.12.2/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 10.0.12.2
  Backup Designated router (ID) 1.1.1.1, Interface address 10.0.12.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 2
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 1.1.1.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
  Simple password authentication enabled

ネイバーテーブルを確認して所望のネイバーが認識されていることを確認する。

R2#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        00:00:37    10.0.12.1       FastEthernet0/0
3.3.3.3           0   FULL/  -        00:00:33    10.1.23.3       Serial0/0

おことわり

これは「徹底攻略Cisco CCNP Routing & Switching ROUTE教科書[300-101J]対応 徹底攻略シリーズ」に掲載されているサンプルトポロジのコンフィグを自分で考えて、インターフェイスの対応等微妙に変えて GNS3, あるいは VIRL のプロジェクトファイルとしています。
具体的な説明はここではせず、箇条書き程度の自分用のメモ、コンフィグ、実際の出力結果を載せています。
詳細なコンセプトの説明はこのテキストを参照するか、他のサイトをあたることをおすすめします。

追記

コンフィグやトポロジに誤りがありましたら指摘いただけるとうれしいです!

なんでこんなこと書いているか

Cisco の試験に限らないですけど、私の基本的なスタンスを書いてあります。
随時アップデートしていくので興味あったら覗いてみてください。

Cisco の技術者認定試験における私のスタンス | wnoguchi’s diary

参考書紹介

こちらのテキストを使用させていただいております。
いつもありがとうございます。

個人的なおすすめはテキストは紙版と Kindle 版両方買っておいて、ウォークスルー的なテキストの読み込みは
クロスリファレンスが必要なときは紙の本をざっと開くのがおすすめです。
問題集は紙版さえあればいいかなと思ってますが、もしかすると Kindle 版のほうが効率いいのかも。
どうなんだろ。

NSSA(Not So Stubby Area) の実装

  1. 対応ページ: pp.208-221
  2. 対応試験: CCNPv2.0 Routing and Switching 300-101J ROUTE
  3. カテゴリ: OSPF
  4. サブカテゴリ: NSSA
  5. IOS: c3725-adventerprisek9-mz.124-15.T14.bin

NSSAについて

Not So Stubby Area の略。
直訳すれば「それほどにスタブじゃないエリア」。
つまり

  1. ASBR(AS Boundary Router) を配置できるようにスタブエリアを拡張した RFC 準拠のエリアである
  2. ABR はスタブエリアと同様に LSA タイプ4, 5 をブロックする
  3. NSSA 内の ASBR はタイプ 5 の LSA が禁止されているので代わりにタイプ 7 の LSA を使う
  4. ABR はタイプ 7 の LSA をタイプ 5 の LSA に変換する
  5. バックボーンエリア、仮想リンク(Virtual Link)のトランジットエリアを NSSA にすることはできない
  6. NSSA エリアではデフォルトでは ABR はデフォルトルートをアドバタイズしない
    なぜなら ABR の先に外部 AS ネットワークがあるとは限らないから
  7. デフォルトルートのコスト変更

    area <area-id> default-cost <cost>
    

    トポロジ

    GNS3 プロジェクトファイルダウンロード

    NSSA 設定前のものです。
    OSPF, EIGRP, RIPv2 、ルート再配布まわりは設定済みです。

    GNS3 1.5.x では Windows, Mac 間の portable project のエクスポート、インポートがうまくいかない | | wnoguchi’s diary

    Windows

    ospf-nssa-win.gns3project

    Mac

    TODO

    基本設定

    R1(ASBR) EIGRP ドメイン

    conf t
    int s0/1
    ip addr 172.16.0.1 255.255.255.0
    no shut
    int s0/0
    ip addr 10.0.12.1 255.255.255.0
    no shut
    !
    ! OSPF configuration
    router ospf 1
    ! Redistribute EIGRP Route to OSPF
    redistribute eigrp 1 subnets
    router-id 1.1.1.1
    network 10.0.0.0 0.255.255.255 area 0
    !
    ! EIGRP configuration
    router eigrp 1
    ! Redistribute OSPF Route to EIGRP
    redistribute ospf 1
    default-metric 10000 100 255 1 1500
    network 172.16.0.0
    no auto-summary
    end
    wr
    

    R2

    conf t
    int s0/0
    ip addr 10.0.12.2 255.255.255.0
    no shut
    int f0/0
    ip addr 10.0.23.2 255.255.255.0
    no shut
    int f0/1
    ip addr 10.0.2.2 255.255.255.0
    no shut
    !
    ! OSPF configuration
    router ospf 1
    router-id 2.2.2.2
    network 10.0.0.0 0.255.255.255 area 0
    end
    wr
    

    R3(ABR)

    conf t
    int f0/0
    ip addr 10.0.23.3 255.255.255.0
    no shut
    int s0/0
    ip addr 10.1.34.3 255.255.255.0
    no shut
    !
    ! OSPF configuration
    router ospf 1
    router-id 3.3.3.3
    network 10.0.23.0 0.0.0.255 area 0
    network 10.1.34.0 0.0.0.255 area 1
    end
    wr
    

    R4

    conf t
    int s0/0
    ip addr 10.1.34.4 255.255.255.0
    no shut
    int f0/0
    ip addr 10.1.45.4 255.255.255.0
    no shut
    !
    ! OSPF configuration
    router ospf 1
    router-id 4.4.4.4
    network 10.0.0.0 0.255.255.255 area 1
    end
    wr
    

    R5(ASBR) RIPv2 ドメイン

    conf t
    int f0/0
    ip addr 10.1.45.5 255.255.255.0
    no shut
    int f0/1
    ip addr 10.1.5.5 255.255.255.0
    no shut
    int s0/1
    ip address 192.168.1.5 255.255.255.0
    no shut
    !
    ! OSPF configuration
    router ospf 1
    router-id 5.5.5.5
    ! Redistribute RIPv2 Route to OSPF
    redistribute rip subnets
    network 10.0.0.0 0.255.255.255 area 1
    !
    ! RIPv2 configuration
    router rip
    version 2
    ! Redistribute OSPF Route to RIP
    redistribute ospf 1 metric 5
    network 192.168.1.0
    no auto-summary
    end
    wr
    

    R6 EIGRP AS1 ドメイン

    conf t
    int s0/0
    ip address 172.16.0.6 255.255.255.0
    no shut
    int f0/0
    ip address 172.16.1.6 255.255.255.0
    no shut
    int f0/1
    ip address 172.16.2.6 255.255.255.0
    no shut
    int f1/0
    ip address 172.16.3.6 255.255.255.0
    no shut
    !
    ! EIGRP configuration
    router eigrp 1
    network 172.16.0.0
    no auto-summary
    end
    wr
    

    R7 RIPv2 ドメイン

    conf t
    int s0/0
    ip addr 192.168.1.7 255.255.255.0
    no shut
    int f0/0
    ip addr 192.168.2.7 255.255.255.0
    no shut
    int f0/1
    ip addr 192.168.3.7 255.255.255.0
    no shut
    !
    ! RIPv2 configuration
    router rip
    version 2
    network 192.168.1.0
    network 192.168.2.0
    network 192.168.3.0
    no auto-summary
    end
    wr
    

    VPCs

    PC1

    ip 10.0.2.21 255.255.255.0 10.0.2.2
    save
    

    PC2

    ip 10.1.5.52 255.255.255.0 10.1.5.5
    save
    

    PC3

    ip 172.16.1.63 255.255.255.0 172.16.1.6
    save
    

    PC4

    ip 172.16.2.64 255.255.255.0 172.16.2.6
    save
    

    PC5

    ip 172.16.3.65 255.255.255.0 172.16.3.6
    save
    

    PC6

    ip 192.168.2.76 255.255.255.0 192.168.2.7
    save
    

    PC7

    ip 192.168.3.77 255.255.255.0 192.168.3.7
    save
    

    設定前の動作確認

    NSSA 設定前の動作を確認する。
    スタブエリア設定前のルーティングテーブルは以下のようになる。

    R4#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         172.16.0.0/24 is subnetted, 4 subnets
    O E2    172.16.0.0 [110/20] via 10.1.34.3, 01:52:21, Serial0/0
    O E2    172.16.1.0 [110/20] via 10.1.34.3, 01:52:20, Serial0/0
    O E2    172.16.2.0 [110/20] via 10.1.34.3, 01:52:20, Serial0/0
    O E2    172.16.3.0 [110/20] via 10.1.34.3, 01:52:19, Serial0/0
         10.0.0.0/24 is subnetted, 6 subnets
    O IA    10.0.12.0 [110/138] via 10.1.34.3, 01:52:26, Serial0/0
    O IA    10.0.2.0 [110/84] via 10.1.34.3, 01:52:26, Serial0/0
    O       10.1.5.0 [110/20] via 10.1.45.5, 01:50:28, FastEthernet0/0
    O IA    10.0.23.0 [110/74] via 10.1.34.3, 01:52:47, Serial0/0
    C       10.1.45.0 is directly connected, FastEthernet0/0
    C       10.1.34.0 is directly connected, Serial0/0
    O E2 192.168.1.0/24 [110/20] via 10.1.45.5, 01:50:28, FastEthernet0/0
    O E2 192.168.2.0/24 [110/20] via 10.1.45.5, 01:50:07, FastEthernet0/0
    O E2 192.168.3.0/24 [110/20] via 10.1.45.5, 01:50:07, FastEthernet0/0
    

    設定

    R3(ABR)

    conf t
    router ospf 1
    area 1 nssa default-information-originate
    end
    

    テキストには area 1 nssa default-information originate と書いてあるけどどのバージョンの IOS のコマンドなんだろ。。。
    つーか、テキストのいっちゃん最初に IOS 15 に基づいてなんちゃらって書いてあるな。。。

    こういうとき役立つのが IOS 15 の載っている実機や VIRL 。

    と思って Cisco 1841 (c1841-adventerprisek9-mz.151-4.M10.bin) の実機で確認したけど default-information-originate だったぞ。。

    R4(内部ルータ)

    conf t
    router ospf 1
    area 1 nssa
    end
    

    R5(ASBR)

    conf t
    router ospf 1
    area 1 nssa
    end
    

    検証

    NSSA 設定後の内部ルータ R4 の LSDB

    R4#sh ip ospf database
    
                OSPF Router with ID (4.4.4.4) (Process ID 1)
    
                    Router Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    3.3.3.3         3.3.3.3         130         0x80000003 0x00947F 2
    4.4.4.4         4.4.4.4         119         0x80000006 0x00AFCC 3
    5.5.5.5         5.5.5.5         120         0x80000005 0x00A1AF 2
    
                    Net Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum
    10.1.45.5       5.5.5.5         120         0x80000003 0x006C50
    
                    Summary Net Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum
    10.0.2.0        3.3.3.3         156         0x80000002 0x000307
    10.0.12.0       3.3.3.3         156         0x80000002 0x00B217
    10.0.23.0       3.3.3.3         156         0x80000003 0x00B449
    
                    Type-7 AS External Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum Tag
    0.0.0.0         3.3.3.3         156         0x80000001 0x00B2F2 0
    192.168.1.0     5.5.5.5         126         0x80000001 0x000201 0
    192.168.2.0     5.5.5.5         126         0x80000001 0x00F60B 0
    192.168.3.0     5.5.5.5         126         0x80000001 0x00EB15 0
    

    LSA タイプ 7 の詳細情報

    R4#show ip ospf database nssa-external
    
                OSPF Router with ID (4.4.4.4) (Process ID 1)
    
                    Type-7 AS External Link States (Area 1)
    
      Routing Bit Set on this LSA
      LS age: 1720
      Options: (No TOS-capability, No Type 7/5 translation, DC)
      LS Type: AS External Link
      Link State ID: 0.0.0.0 (External Network Number )
      Advertising Router: 3.3.3.3
      LS Seq Number: 80000003
      Checksum: 0xAEF4
      Length: 36
      Network Mask: /0
            Metric Type: 2 (Larger than any link state path)
            TOS: 0
            Metric: 1
            Forward Address: 0.0.0.0
            External Route Tag: 0
    
      Routing Bit Set on this LSA
      LS age: 1689
      Options: (No TOS-capability, Type 7/5 translation, DC)
      LS Type: AS External Link
      Link State ID: 192.168.1.0 (External Network Number )
      Advertising Router: 5.5.5.5
      LS Seq Number: 80000003
      Checksum: 0xFD03
      Length: 36
      Network Mask: /24
            Metric Type: 2 (Larger than any link state path)
            TOS: 0
            Metric: 20
            Forward Address: 10.1.5.5
            External Route Tag: 0
    
      Routing Bit Set on this LSA
      LS age: 1690
      Options: (No TOS-capability, Type 7/5 translation, DC)
      LS Type: AS External Link
      Link State ID: 192.168.2.0 (External Network Number )
      Advertising Router: 5.5.5.5
      LS Seq Number: 80000003
      Checksum: 0xF20D
      Length: 36
      Network Mask: /24
            Metric Type: 2 (Larger than any link state path)
            TOS: 0
            Metric: 20
            Forward Address: 10.1.5.5
            External Route Tag: 0
    
      Routing Bit Set on this LSA
      LS age: 1691
      Options: (No TOS-capability, Type 7/5 translation, DC)
      LS Type: AS External Link
      Link State ID: 192.168.3.0 (External Network Number )
      Advertising Router: 5.5.5.5
      LS Seq Number: 80000003
      Checksum: 0xE717
      Length: 36
      Network Mask: /24
            Metric Type: 2 (Larger than any link state path)
            TOS: 0
            Metric: 20
            Forward Address: 10.1.5.5
            External Route Tag: 0
    

    NSSA 設定後の内部ルータ R4 の ルーティングテーブル

    R4#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 10.1.34.3 to network 0.0.0.0
    
         10.0.0.0/24 is subnetted, 6 subnets
    O IA    10.0.12.0 [110/138] via 10.1.34.3, 00:02:19, Serial0/0
    O IA    10.0.2.0 [110/84] via 10.1.34.3, 00:02:19, Serial0/0
    O       10.1.5.0 [110/20] via 10.1.45.5, 00:02:09, FastEthernet0/0
    O IA    10.0.23.0 [110/74] via 10.1.34.3, 00:02:19, Serial0/0
    C       10.1.45.0 is directly connected, FastEthernet0/0
    C       10.1.34.0 is directly connected, Serial0/0
    O N2 192.168.1.0/24 [110/20] via 10.1.45.5, 00:02:09, FastEthernet0/0
    O N2 192.168.2.0/24 [110/20] via 10.1.45.5, 00:02:11, FastEthernet0/0
    O N2 192.168.3.0/24 [110/20] via 10.1.45.5, 00:02:11, FastEthernet0/0
    O*N2 0.0.0.0/0 [110/1] via 10.1.34.3, 00:02:21, Serial0/0
    

    上記から分かるとおり、R3(ABR) はタイプ 5 LSA でアドバタイズされる EIGRP ドメインのルート情報をブロックしている。
    そのかわり default-information-originate でデフォルトルートを LSA タイプ 7 でアドバタイズしている。

    また R2 は R3 から RIP のルート情報を LSA タイプ 5 に変換されたものを受け取っている。

    R2#sh ip ospf database external 192.168.1.0
    
                OSPF Router with ID (2.2.2.2) (Process ID 1)
    
                    Type-5 AS External Link States
    
      Routing Bit Set on this LSA
      LS age: 278
      Options: (No TOS-capability, DC)
      LS Type: AS External Link
      Link State ID: 192.168.1.0 (External Network Number )
      Advertising Router: 3.3.3.3
      LS Seq Number: 80000001
      Checksum: 0xD242
      Length: 36
      Network Mask: /24
            Metric Type: 2 (Larger than any link state path)
            TOS: 0
            Metric: 20
            Forward Address: 10.1.5.5
            External Route Tag: 0
    

    R2 (バックボーンエリアの内部ルータ)のルーティングテーブル

    R2#sh ip ro
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         172.16.0.0/24 is subnetted, 4 subnets
    O E2    172.16.0.0 [110/20] via 10.0.12.1, 00:12:42, Serial0/0
    O E2    172.16.1.0 [110/20] via 10.0.12.1, 00:12:42, Serial0/0
    O E2    172.16.2.0 [110/20] via 10.0.12.1, 00:12:42, Serial0/0
    O E2    172.16.3.0 [110/20] via 10.0.12.1, 00:12:42, Serial0/0
         10.0.0.0/24 is subnetted, 6 subnets
    C       10.0.12.0 is directly connected, Serial0/0
    C       10.0.2.0 is directly connected, FastEthernet0/1
    O IA    10.1.5.0 [110/94] via 10.0.23.3, 00:06:28, FastEthernet0/0
    C       10.0.23.0 is directly connected, FastEthernet0/0
    O IA    10.1.45.0 [110/84] via 10.0.23.3, 00:06:39, FastEthernet0/0
    O IA    10.1.34.0 [110/74] via 10.0.23.3, 00:11:59, FastEthernet0/0
    O E2 192.168.1.0/24 [110/20] via 10.0.23.3, 00:06:23, FastEthernet0/0
    O E2 192.168.2.0/24 [110/20] via 10.0.23.3, 00:06:24, FastEthernet0/0
    O E2 192.168.3.0/24 [110/20] via 10.0.23.3, 00:06:24, FastEthernet0/0
    

    トターリーNSSA

    Cisco 独自の拡張。
    LSA タイプ 3 もブロックする。
    すなわちデフォルトルートによって基本的に外部エリア、AS との通信はおこなう。
    タイプ 1, 2 および 7 のみ。

    (config-router)#area <area-id> nssa no-summary
    

    デフォルトルートを生成することが前提のため、 default-information-originate は不要である。

    R3(ABR)

    router ospf 1
    area 1 nssa no-summary
    

    R4 の LSDB

    R4#sh ip ospf database
    
                OSPF Router with ID (4.4.4.4) (Process ID 1)
    
                    Router Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    3.3.3.3         3.3.3.3         1580        0x80000003 0x00947F 2
    4.4.4.4         4.4.4.4         1572        0x80000006 0x00AFCC 3
    5.5.5.5         5.5.5.5         1572        0x80000005 0x00A1AF 2
    
                    Net Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum
    10.1.45.5       5.5.5.5         1572        0x80000003 0x006C50
    
                    Summary Net Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum
    0.0.0.0         3.3.3.3         727         0x80000001 0x00DE4B
    
                    Type-7 AS External Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum Tag
    0.0.0.0         3.3.3.3         1589        0x80000001 0x00B2F2 0
    192.168.1.0     5.5.5.5         1578        0x80000001 0x000201 0
    192.168.2.0     5.5.5.5         1578        0x80000001 0x00F60B 0
    192.168.3.0     5.5.5.5         1578        0x80000001 0x00EB15 0
    

    R4 のタイプ 3 LSA の詳細表示

    R4#sh ip ospf da sum
    
                OSPF Router with ID (4.4.4.4) (Process ID 1)
    
                    Summary Net Link States (Area 1)
    
      Routing Bit Set on this LSA
      LS age: 902
      Options: (No TOS-capability, DC, Upward)
      LS Type: Summary Links(Network)
      Link State ID: 0.0.0.0 (summary Network Number)
      Advertising Router: 3.3.3.3
      LS Seq Number: 80000001
      Checksum: 0xDE4B
      Length: 28
      Network Mask: /0
            TOS: 0  Metric: 1
    

    R4 のルーティングテーブル

    R4#sh ip ro
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 10.1.34.3 to network 0.0.0.0
    
         10.0.0.0/24 is subnetted, 3 subnets
    O       10.1.5.0 [110/20] via 10.1.45.5, 00:14:50, FastEthernet0/0
    C       10.1.45.0 is directly connected, FastEthernet0/0
    C       10.1.34.0 is directly connected, Serial0/0
    O N2 192.168.1.0/24 [110/20] via 10.1.45.5, 00:14:50, FastEthernet0/0
    O N2 192.168.2.0/24 [110/20] via 10.1.45.5, 00:14:50, FastEthernet0/0
    O N2 192.168.3.0/24 [110/20] via 10.1.45.5, 00:14:50, FastEthernet0/0
    O*IA 0.0.0.0/0 [110/65] via 10.1.34.3, 00:00:48, Serial0/0
    

    EIGRP ルートが消えてスッキリしましたね。

    おことわり

    これは「徹底攻略Cisco CCNP Routing & Switching ROUTE教科書[300-101J]対応 徹底攻略シリーズ」に掲載されているサンプルトポロジのコンフィグを自分で考えて、インターフェイスの対応等微妙に変えて GNS3, あるいは VIRL のプロジェクトファイルとしています。
    具体的な説明はここではせず、箇条書き程度の自分用のメモ、コンフィグ、実際の出力結果を載せています。
    詳細なコンセプトの説明はこのテキストを参照するか、他のサイトをあたることをおすすめします。

    追記

    コンフィグやトポロジに誤りがありましたら指摘いただけるとうれしいです!

    なんでこんなこと書いているか

    Cisco の試験に限らないですけど、私の基本的なスタンスを書いてあります。
    随時アップデートしていくので興味あったら覗いてみてください。

    Cisco の技術者認定試験における私のスタンス | wnoguchi’s diary

    参考書紹介

    こちらのテキストを使用させていただいております。
    いつもありがとうございます。

    個人的なおすすめはテキストは紙版と Kindle 版両方買っておいて、ウォークスルー的なテキストの読み込みは
    クロスリファレンスが必要なときは紙の本をざっと開くのがおすすめです。
    問題集は紙版さえあればいいかなと思ってますが、もしかすると Kindle 版のほうが効率いいのかも。
    どうなんだろ。

Cisco の技術者認定試験における私のスタンス

導入

ちょっと主語が大きすぎるだろうか?
最近やっと CCNAv3.0 R&S (Routing and Switching) のトラックを取得することができました。
今は CCNPv2.0 の ROUTE 試験のトラックの学習をしています。

なので CCNAv3.0 R&S レベルの時点での私のネットワークの技術習得に関する考えを書いています。
他のブログ記事でコンフィグとトポロジー、GNS プロジェクトファイルを載せている理由も書いています。
すでに CCNP, CCIE 持ってるしマルチベンダでバリバリやってるぜって人は時間を無駄にしたくない人はそっ閉じしてください。
マサカリ投げたい人ははてブやコメント欄でどうぞ。
あくまで一個人の意見です。

お前誰だよ?

現場ではインフラ側で YAMAHA ルーター等を中心に中小ブランチネットワークや拠点間の VPN 設計・実装等をやっています。
どちらかというとサーバー要素多めで、最近はオンプレで食っていくには小手先のネットワーク知識じゃだめだなと思って Cisco の技術者認定資格の取得に力を入れています。

ネットワークの技術の学習方法

私は実機、シミュレータで実際に動かしてみないとその技術のコンセプトが理解できないたちなので、
テキストや問題集に載っているやつは実際にトポロジを組んでシミュレーターで動かしてコマンド打ち込んでルーターの動きがどう変わるかちゃんと見て理解した上で進めています。

実機をいつ使うか?

実機使うのは本当に基礎的なトピックを理解するために使います。

  1. 物理層(L1)、データリンク層(L2)の細かい動きを確認して実機の動きとシミュレーター上での動きはどう違うのか理解する。
    1. Cisco VIRL で IOSvL2 で STP 実験してみようと思ったらリンク状態が全二重じゃなくて半二重になってて全然意味わからなかったときとかあります。
    2. MDI 同士、MDI-X 同士をつなぐときはクロスケーブル使わないと物理層レベルでだけ up してデータリンク層レベルでは down するよとか。
    3. 今まで Auto MDI/MDI-X に頼ってばかりいましたけど、Cisco ルーター同士をストレート(今市場に大量に出回っているのがこればっかし)直結すると no shut してもリンクアップしなくて困ったりとか。
  2. ロールオーバー(シリアルコンソール)ケーブルをつなぐときはクロスケーブル(だいたいこっちでいい)、ストレートケーブル間違えると正常につなげらんないよとか。
  3. 新しいコンセプトの Hello World 的な構成を試す時とか(RIP, EIGRP, OSPF)。
  4. STP の三角形とか、自分自身につないでループする構成とか(下記)。

ループ接続のイラスト | かわいいフリー素材集 いらすとや

シミュレーターの使い所

シミュレーターを使うのは基本的なこと理解したらようし複数台構成してもっと深いコンセプトを理解するぞってときにやります。
正直 CCNP レベルになってくるとルーターの数 5 台のトポロジとか解説に平気で出てくるので毎回実機使ってたらやってらんないので GNS3 や Cisco VIRL を使っています。。。。
初めてのコンセプトの実装・検証は上記のとおり実機でやります。

実務的な面

いくらシミュレーターで検証しようが、 Visio トポロジーをきれいに書こうが実際にデプロイされるのは物理的な環境です。
いざネットワーク機器の実機や VyOS の VM を目の前にして慌てるようでは目も当てられません。

Cisco 試験の方法論

本読んでひたすら問題集解いて試験 Pass できる人はいいなあと思います。
コンセプト理解しただけで他のベンダのネットワーク機器のマニュアル読んでふんふん設計・設定できるほど私は頭良くないので。。。

まあ、コンセプト理解するだけじゃなくて試験対策として問題集、や ping-t やりまくるのは必要ですけど。
最近は円安が進んで試験の値段がどんどん値上がりしています。
一回落ちると 4 万近くが吹っ飛んでいきます。
順当に CCNP ROUTE, SWITCH, TSHOOT に Pass したとしても 12 万近く吹っ飛ぶわけです。
軽い気持ちで受けられないわけです。
まあ、試験自体は東京の Pearson VUE に登録してお気に入りの試験センター見つけた休みの日にらふらっと行って当日受験なんてことも普通にできますけど。

まとめ

ということでテキストを読むだけでなく、コンセプトをちゃんと(私が)理解するためにテキストには書かれないコンフィグをちゃんと載せて、 GNS3 のプロジェクトファイルも載せているわけです。

EtherChannel でガチャガチャいじくって遊んでたら err-disabled になった

ちなみに再起動しても err-disabled のままとのこと。
再起動したら( config 保存してないから) EtherChannel の設定も消えて err-disabled もなかったから(なぜなら Po1 インタフェース自体存在しなくなるから)、
たぶん config 保存した状態でリブートしたらそうなるって感じかな。

interface configuration mode に入ってから

shutdown
no shutdown

するのがポイント。

*Mar  2 00:06:25.742: %PM-4-ERR_DISABLE: channel-misconfig (STP) error detected on Fa0/1, putting Fa0/1 in err-disable state
*Mar  2 00:06:25.742: %PM-4-ERR_DISABLE: channel-misconfig (STP) error detected on Fa0/2, putting Fa0/2 in err-disable state
*Mar  2 00:06:25.750: %PM-4-ERR_DISABLE: channel-misconfig (STP) error detected on Po1, putting Fa0/1 in err-disable state
*Mar  2 00:06:25.750: %PM-4-ERR_DISABLE: channel-misconfig (STP) error detected on Po1, putting Fa0/2 in err-disable state
*Mar  2 0
ASW1#0:06:25.750: %PM-4-ERR_DISABLE: channel-misconfig (STP) error detected on Po1, putting Po1 in err-disable state
*Mar  2 00:06:25.767: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
*Mar  2 00:06:26.749: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
*Mar  2 00:06:26.749: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
ASW1#sh int po1
Port-channel1 is down, line protocol is down (err-disabled)
  Hardware is EtherChannel, address is 0022.bd89.2182 (bia 0022.bd89.2182)
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto-speed, link type is auto, media type is unknown
  input flow-control is off, output flow-control is unsupported

回復させる

ASW1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
ASW1(config)#int shu
ASW1(config)#int po1
ASW1(config-if)#shu
ASW1(config-if)#shutdown
ASW1(config-if)#no shu
ASW1(config-if)#no shutdown
*Mar  2 00:12:36.888: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
*Mar  2 00:12:36.888: %LINK-5-CHANGED: Interface FastEthernet0/2, changed state to administratively down
*Mar  2 00:12:36.888: %LINK-5-CHANGED: Interface Port-channel1, changed state to administratively down
ASW1(config-if)#no shutdown
ASW1(config-if)#^Z
ASW1#
*Mar  2 00:12:43.204: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
*Mar  2 00:12:43.204: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Mar  2 00:12:43.213: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up
ASW1#
*Mar  2 00:12:43.380: %SYS-5-CONFIG_I: Configured from console by console
*Mar  2 00:12:44.211: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
*Mar  2 00:12:44.211: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
*Mar  2 00:12:44.219: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
ASW1#sh e
ASW1#sh eth
ASW1#sh etherchannel 1 su
ASW1#sh etherchannel 1 summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)          -        Fa0/1(P)    Fa0/2(P)

Cisco err-disableを戻す&自動回復させてみよう の巻 | Network For Everyone

Catalyst 2960 シリーズの IOS を復活させる

一言で言うと Catalyst スイッチの設定を消そうとして CF カード内にある IOS も一緒に消しちゃいましたーということです。
本当は delete flash:vlan.dat がしたかった。
フラッシュメモリ内のファイルが全部消えるけどええのんか?って聞かれたんだけど、どうせあっても vlan.dat だろーって思ってたら違った。
CF カードには IOS も入ってる!!!!!!!
ッターンとエンターキーを押して気づいたときには時すでに遅し。

Switch#erase flash:
Erasing the flash filesystem will remove all files! Continue? [confirm]

Using driver version 1 for media type 1
Base ethernet MAC Address: 00:22:bd:89:21:80
Xmodem file system is available.
The password-recovery mechanism is enabled.
Initializing Flash...
mifs[2]: 0 files, 1 directories
mifs[2]: Total bytes     :    3870720
mifs[2]: Bytes used      :       1024
mifs[2]: Bytes available :    3869696
mifs[2]: mifs fsck took 0 seconds.
mifs[3]: 0 files, 1 directories
mifs[3]: Total bytes     :   27998208
mifs[3]: Bytes used      :       1024
mifs[3]: Bytes available :   27997184
mifs[3]: mifs fsck took 0 seconds.
...done Initializing Flash.
done.
Loading "flash:c2960-lanbasek9-mz.150-2.SE8/c2960-lanbasek9-mz.150-2.SE8.bin"...flash:c2960-lanbasek9-mz.150-2.SE8/c2960-lanbasek9-mz.150-2.SE8.bin: no such file or directory

Error loading "flash:c2960-lanbasek9-mz.150-2.SE8/c2960-lanbasek9-mz.150-2.SE8.bin"

Interrupt within 5 seconds to abort boot process.
Boot process failed...

The system is unable to boot automatically.  The BOOT
environment variable needs to be set to a bootable
image.


switch:

以下は復旧の記録。
tar で固めた IOS があるんですが、 boot loader にそんな高等機能はないので tar の中にある bin 取り出してそれを XMODEM 転送しました。

switch: copy xmodem: flash:c2960-lanbasek9-mz.150-2.SE8.bin
Begin the Xmodem or Xmodem-1K transfer now...
C

2016-11-20_21h54_35

...........................................................................................
File "xmodem:" successfully copied to "flash:c2960-lanbasek9-mz.150-2.SE8.bin"
switch: help
           ? -- Present list of available commands
        boot -- Load and boot an executable image
         cat -- Concatenate (type) file(s)
        copy -- Copy a file
      delete -- Delete file(s)
         dir -- List files in directories
  flash_init -- Initialize flash filesystem(s)
      format -- Format a filesystem
        fsck -- Check filesystem consistency
        help -- Present list of available commands
      memory -- Present memory heap utilization information
       mkdir -- Create dir(s)
        more -- Concatenate (display) file(s)
      rename -- Rename a file
       reset -- Reset the system
       rmdir -- Delete empty dir(s)
         set -- Set or display environment variables
      set_bs -- Set attributes on a boot sector filesystem
   set_param -- Set system parameters in flash
       sleep -- Pause (sleep) for a specified number of seconds
        type -- Concatenate (type) file(s)
 -- MORE --
       unset -- Unset one or more environment variables
     version -- Display boot loader version

switch: dir flash:
Directory of flash:/

    2  -rwx  11834880                 c2960-lanbasek9-mz.150-2.SE8.bin

16066560 bytes available (11931648 bytes used)
switch: boot flash:c2960-lanbasek9-mz.150-2.SE8.bin
Loading "flash:c2960-lanbasek9-mz.150-2.SE8.bin"...@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
File "flash:c2960-lanbasek9-mz.150-2.SE8.bin" uncompressed and installed, entry point: 0x3000
executing...

              Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.
           170 West Tasman Drive
           San Jose, California 95134-1706



Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 15.0(2)SE8, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2015 by Cisco Systems, Inc.
Compiled Thu 14-May-15 02:39 by prod_rel_teamInitializing flashfs...
Using driver version 3 for media type 1
mifs[4]: 0 files, 1 directories
mifs[4]: Total bytes     : 3870720
mifs[4]: Bytes used      : 1024
mifs[4]: Bytes available : 3869696
mifs[4]: mifs fsck took 0 seconds.
mifs[4]: Initialization complete.

mifs[5]: 1 files, 1 directories
mifs[5]: Total bytes     : 27998208
mifs[5]: Bytes used      : 11931648
mifs[5]: Bytes available : 16066560
mifs[5]: mifs fsck took 0 seconds.
mifs[5]: Initialization complete.

...done Initializing flashfs.
Checking for Bootloader upgrade..
Boot Loader upgrade not required (Stage 2)

POST: CPU MIC register Tests : Begin
POST: CPU MIC register Tests : End, Status Passed

POST: PortASIC Memory Tests : Begin
POST: PortASIC Memory Tests : End, Status Passed

POST: CPU MIC interface Loopback Tests : Begin
POST: CPU MIC interface Loopback Tests : End, Status Passed

POST: PortASIC RingLoopback Tests : Begin
POST: PortASIC RingLoopback Tests : End, Status Passed

POST: PortASIC CAM Subsystem Tests : Begin
POST: PortASIC CAM Subsystem Tests : End, Status Passed

POST: PortASIC Port Loopback Tests : Begin
POST: PortASIC Port Loopback Tests : End, Status Passed

Waiting for Port download...Complete


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco WS-C2960-8TC-L (PowerPC405) processor (revision A0) with 65536K bytes of memory.
Processor board ID FOC1230U65J
Last reset from power-on
1 Virtual Ethernet interface
8 FastEthernet interfaces
1 Gigabit Ethernet interface
The password-recovery mechanism is enabled.

64K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address       : 00:22:BD:89:21:80
Motherboard assembly number     : 73-10611-07
Power supply part number        : 341-0208-01
Motherboard serial number       : FOC12287J8F
Power supply serial number      : LIT12260BQV
Model revision number           : A0
Motherboard revision number     : C0
Model number                    : WS-C2960-8TC-L
System serial number            : FOC1230U65J
Top Assembly Part Number        : 800-28132-01
Top Assembly Revision Number    : C0
Version ID                      : V01
CLEI Code Number                : COM8A00ARA
Hardware Board Revision Number  : 0x01


Switch Ports Model              SW Version            SW Image
------ ----- -----              ----------            ----------
*    1 9     WS-C2960-8TC-L     15.0(2)SE8            C2960-LANBASEK9-M




Press RETURN to get started!


*Mar  1 00:00:33.839: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
*Mar  1 00:00:34.225: %SPANTREE-5-EXTENDED_SYSID: Extended SysId enabled for type vlan
*Mar  1 00:00:35.282: %DC-4-FILE_OPEN_WARNING: Not able to open flash:/dc_profile_dir/dc_default_profiles.txt
*Mar  1 00:00:35.282: %DC-6-DEFAULT_INIT_INFO: Default Profiles DB not loaded.
*Mar  1 00:00:55.641: %SYS-5-RESTART: System restarted --
Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 15.0(2)SE8, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2015 by Cisco Systems, Inc.
Compiled Thu 14-May-15 02:39 by prod_rel_team


         --- System Configuration Dialog ---

Enable secret warning
----------------------------------
In order to access the device manager, an enable secret is required
If you enter the initial configuration dialog, you will be prompted for the enable secret
If you choose not to enter the intial configuration dialog, or if you exit setup without setting the enable secret,
please set an enable secret using the following CLI in configuration mode-
enable secret 0 
----------------------------------
Would you like to enter the initial configuration dialog? [yes/no]: no
Switch>en
Switch#
  • Ciscoデバイスの管理 – Catalystスイッチ – xmodemによるIOSのダウンロード
  • シリアルインターフェイスのコントローラタイプを確認する

    Router#sh controllers serial 0/0/0
    Interface Serial0/0/0
    Hardware is GT96K
    DTE V.35 clocks stopped.
    idb at 0x66C2C7E0, driver data structure at 0x66C33FFC
    wic_info 0x66C34628
    Physical Port 0, SCC Num 0
    MPSC Registers:
    MMCR_L=0x00030400, MMCR_H=0x00000000, MPCR=0x00000000
    CHR1=0x00FE007E, CHR2=0x80000000, CHR3=0x0000064A, CHR4=0x00000000
    CHR5=0x00000000, CHR6=0x00000000, CHR7=0x00000000, CHR8=0x00000000
    CHR9=0x00000000, CHR10=0x00000003
    SDMA Registers:
    SDC=0x00002201, SDCM=0x00000000, SGC=0x0000C000
    CRDP=0x15BD6FA0, CTDP=0x15BD71E0, FTDB=0x15BD71E0
    Main Routing Register=0x0003FFF8 BRG Conf Register=0x00490013
    Rx Clk Routing Register=0x76543218 Tx Clk Routing Register=0x76543210
    GPP Registers:
    Conf=0x430002  , Io=0x464050  , Data=0x7F5FFFAF, Level=0x0
    Conf0=0x430002  , Io0=0x464050  , Data0=0x7F5FFFAF, Level0=0x0
    0 input aborts on receiving flag sequence
    0 throttles, 0 enables
    0 overruns
    0 transmitter underruns
    0 transmitter CTS losts
    0 rxintr, 0 txintr, 0 rxerr, 0 txerr
    0 mpsc_rx, 0 mpsc_rxerr, 0 mpsc_rlsc, 0 mpsc_rhnt, 0 mpsc_rfsc
    0 mpsc_rcsc, 0 mpsc_rovr, 0 mpsc_rcdl, 0 mpsc_rckg, 0 mpsc_bper
    0 mpsc_txerr, 0 mpsc_teidl, 0 mpsc_tudr, 0 mpsc_tctsl, 0 mpsc_tckg
    0 sdma_rx_sf, 0 sdma_rx_mfl, 0 sdma_rx_or, 0 sdma_rx_abr, 0 sdma_rx_no
    0 sdma_rx_de, 0 sdma_rx_cdl, 0 sdma_rx_ce, 0 sdma_tx_rl, 0 sdma_tx_ur, 0 sdma_tx_ctsl
    0 sdma_rx_reserr, 0 sdma_tx_reserr
    0 rx_bogus_pkts, rx_bogus_flag FALSE
    0 sdma_tx_ur_processed
    
    tx_limited = 1(2), errata19 count1 - 0, count2 - 0
    Receive Ring
    rxr head (0)(0x15BD6FA0), rxr tail (0)(0x15BD6FA0)
      rmd(15BD6FA0): nbd 15BD6FB0 cmd_sts 80800000 buf_sz 06000000 buf_ptr 15BD7A80
      rmd(15BD6FB0): nbd 15BD6FC0 cmd_sts 80800000 buf_sz 06000000 buf_ptr 15BD80E0
      rmd(15BD6FC0): nbd 15BD6FD0 cmd_sts 80800000 buf_sz 06000000 buf_ptr 15BD8740
      rmd(15BD6FD0): nbd 15BD6FE0 cmd_sts 80800000 buf_sz 06000000 buf_ptr 15BD8DA0
      rmd(15BD6FE0): nbd 15BD6FF0 cmd_sts 80800000 buf_sz 06000000 buf_ptr 15BD9400
      rmd(15BD6FF0): nbd 15BD7000 cmd_sts 80800000 buf_sz 06000000 buf_ptr 15BD9A60
      rmd(15BD7000): nbd 15BD7010 cmd_sts 80800000 buf_sz 06000000 buf_ptr 15BDA0C0
      rmd(15BD7010): nbd 15BD7020 cmd_sts 80800000 buf_sz 06000000 buf_ptr 15BDA720