Catalyst 2960 シリーズの IOS を復活させる

一言で言うと Catalyst スイッチの設定を消そうとして CF カード内にある IOS も一緒に消しちゃいましたーということです。
本当は delete flash:vlan.dat がしたかった。
フラッシュメモリ内のファイルが全部消えるけどええのんか?って聞かれたんだけど、どうせあっても vlan.dat だろーって思ってたら違った。
CF カードには IOS も入ってる!!!!!!!
ッターンとエンターキーを押して気づいたときには時すでに遅し。

Switch#erase flash:
Erasing the flash filesystem will remove all files! Continue? [confirm]

Using driver version 1 for media type 1
Base ethernet MAC Address: 00:22:bd:89:21:80
Xmodem file system is available.
The password-recovery mechanism is enabled.
Initializing Flash...
mifs[2]: 0 files, 1 directories
mifs[2]: Total bytes     :    3870720
mifs[2]: Bytes used      :       1024
mifs[2]: Bytes available :    3869696
mifs[2]: mifs fsck took 0 seconds.
mifs[3]: 0 files, 1 directories
mifs[3]: Total bytes     :   27998208
mifs[3]: Bytes used      :       1024
mifs[3]: Bytes available :   27997184
mifs[3]: mifs fsck took 0 seconds.
...done Initializing Flash.
done.
Loading "flash:c2960-lanbasek9-mz.150-2.SE8/c2960-lanbasek9-mz.150-2.SE8.bin"...flash:c2960-lanbasek9-mz.150-2.SE8/c2960-lanbasek9-mz.150-2.SE8.bin: no such file or directory

Error loading "flash:c2960-lanbasek9-mz.150-2.SE8/c2960-lanbasek9-mz.150-2.SE8.bin"

Interrupt within 5 seconds to abort boot process.
Boot process failed...

The system is unable to boot automatically.  The BOOT
environment variable needs to be set to a bootable
image.


switch:

以下は復旧の記録。
tar で固めた IOS があるんですが、 boot loader にそんな高等機能はないので tar の中にある bin 取り出してそれを XMODEM 転送しました。

switch: copy xmodem: flash:c2960-lanbasek9-mz.150-2.SE8.bin
Begin the Xmodem or Xmodem-1K transfer now...
C

2016-11-20_21h54_35

...........................................................................................
File "xmodem:" successfully copied to "flash:c2960-lanbasek9-mz.150-2.SE8.bin"
switch: help
           ? -- Present list of available commands
        boot -- Load and boot an executable image
         cat -- Concatenate (type) file(s)
        copy -- Copy a file
      delete -- Delete file(s)
         dir -- List files in directories
  flash_init -- Initialize flash filesystem(s)
      format -- Format a filesystem
        fsck -- Check filesystem consistency
        help -- Present list of available commands
      memory -- Present memory heap utilization information
       mkdir -- Create dir(s)
        more -- Concatenate (display) file(s)
      rename -- Rename a file
       reset -- Reset the system
       rmdir -- Delete empty dir(s)
         set -- Set or display environment variables
      set_bs -- Set attributes on a boot sector filesystem
   set_param -- Set system parameters in flash
       sleep -- Pause (sleep) for a specified number of seconds
        type -- Concatenate (type) file(s)
 -- MORE --
       unset -- Unset one or more environment variables
     version -- Display boot loader version

switch: dir flash:
Directory of flash:/

    2  -rwx  11834880                 c2960-lanbasek9-mz.150-2.SE8.bin

16066560 bytes available (11931648 bytes used)
switch: boot flash:c2960-lanbasek9-mz.150-2.SE8.bin
Loading "flash:c2960-lanbasek9-mz.150-2.SE8.bin"...@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
File "flash:c2960-lanbasek9-mz.150-2.SE8.bin" uncompressed and installed, entry point: 0x3000
executing...

              Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.
           170 West Tasman Drive
           San Jose, California 95134-1706



Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 15.0(2)SE8, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2015 by Cisco Systems, Inc.
Compiled Thu 14-May-15 02:39 by prod_rel_teamInitializing flashfs...
Using driver version 3 for media type 1
mifs[4]: 0 files, 1 directories
mifs[4]: Total bytes     : 3870720
mifs[4]: Bytes used      : 1024
mifs[4]: Bytes available : 3869696
mifs[4]: mifs fsck took 0 seconds.
mifs[4]: Initialization complete.

mifs[5]: 1 files, 1 directories
mifs[5]: Total bytes     : 27998208
mifs[5]: Bytes used      : 11931648
mifs[5]: Bytes available : 16066560
mifs[5]: mifs fsck took 0 seconds.
mifs[5]: Initialization complete.

...done Initializing flashfs.
Checking for Bootloader upgrade..
Boot Loader upgrade not required (Stage 2)

POST: CPU MIC register Tests : Begin
POST: CPU MIC register Tests : End, Status Passed

POST: PortASIC Memory Tests : Begin
POST: PortASIC Memory Tests : End, Status Passed

POST: CPU MIC interface Loopback Tests : Begin
POST: CPU MIC interface Loopback Tests : End, Status Passed

POST: PortASIC RingLoopback Tests : Begin
POST: PortASIC RingLoopback Tests : End, Status Passed

POST: PortASIC CAM Subsystem Tests : Begin
POST: PortASIC CAM Subsystem Tests : End, Status Passed

POST: PortASIC Port Loopback Tests : Begin
POST: PortASIC Port Loopback Tests : End, Status Passed

Waiting for Port download...Complete


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco WS-C2960-8TC-L (PowerPC405) processor (revision A0) with 65536K bytes of memory.
Processor board ID FOC1230U65J
Last reset from power-on
1 Virtual Ethernet interface
8 FastEthernet interfaces
1 Gigabit Ethernet interface
The password-recovery mechanism is enabled.

64K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address       : 00:22:BD:89:21:80
Motherboard assembly number     : 73-10611-07
Power supply part number        : 341-0208-01
Motherboard serial number       : FOC12287J8F
Power supply serial number      : LIT12260BQV
Model revision number           : A0
Motherboard revision number     : C0
Model number                    : WS-C2960-8TC-L
System serial number            : FOC1230U65J
Top Assembly Part Number        : 800-28132-01
Top Assembly Revision Number    : C0
Version ID                      : V01
CLEI Code Number                : COM8A00ARA
Hardware Board Revision Number  : 0x01


Switch Ports Model              SW Version            SW Image
------ ----- -----              ----------            ----------
*    1 9     WS-C2960-8TC-L     15.0(2)SE8            C2960-LANBASEK9-M




Press RETURN to get started!


*Mar  1 00:00:33.839: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
*Mar  1 00:00:34.225: %SPANTREE-5-EXTENDED_SYSID: Extended SysId enabled for type vlan
*Mar  1 00:00:35.282: %DC-4-FILE_OPEN_WARNING: Not able to open flash:/dc_profile_dir/dc_default_profiles.txt
*Mar  1 00:00:35.282: %DC-6-DEFAULT_INIT_INFO: Default Profiles DB not loaded.
*Mar  1 00:00:55.641: %SYS-5-RESTART: System restarted --
Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 15.0(2)SE8, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2015 by Cisco Systems, Inc.
Compiled Thu 14-May-15 02:39 by prod_rel_team


         --- System Configuration Dialog ---

Enable secret warning
----------------------------------
In order to access the device manager, an enable secret is required
If you enter the initial configuration dialog, you will be prompted for the enable secret
If you choose not to enter the intial configuration dialog, or if you exit setup without setting the enable secret,
please set an enable secret using the following CLI in configuration mode-
enable secret 0 
----------------------------------
Would you like to enter the initial configuration dialog? [yes/no]: no
Switch>en
Switch#
  • Ciscoデバイスの管理 – Catalystスイッチ – xmodemによるIOSのダウンロード
  • シリアルインターフェイスのコントローラタイプを確認する

    Router#sh controllers serial 0/0/0
    Interface Serial0/0/0
    Hardware is GT96K
    DTE V.35 clocks stopped.
    idb at 0x66C2C7E0, driver data structure at 0x66C33FFC
    wic_info 0x66C34628
    Physical Port 0, SCC Num 0
    MPSC Registers:
    MMCR_L=0x00030400, MMCR_H=0x00000000, MPCR=0x00000000
    CHR1=0x00FE007E, CHR2=0x80000000, CHR3=0x0000064A, CHR4=0x00000000
    CHR5=0x00000000, CHR6=0x00000000, CHR7=0x00000000, CHR8=0x00000000
    CHR9=0x00000000, CHR10=0x00000003
    SDMA Registers:
    SDC=0x00002201, SDCM=0x00000000, SGC=0x0000C000
    CRDP=0x15BD6FA0, CTDP=0x15BD71E0, FTDB=0x15BD71E0
    Main Routing Register=0x0003FFF8 BRG Conf Register=0x00490013
    Rx Clk Routing Register=0x76543218 Tx Clk Routing Register=0x76543210
    GPP Registers:
    Conf=0x430002  , Io=0x464050  , Data=0x7F5FFFAF, Level=0x0
    Conf0=0x430002  , Io0=0x464050  , Data0=0x7F5FFFAF, Level0=0x0
    0 input aborts on receiving flag sequence
    0 throttles, 0 enables
    0 overruns
    0 transmitter underruns
    0 transmitter CTS losts
    0 rxintr, 0 txintr, 0 rxerr, 0 txerr
    0 mpsc_rx, 0 mpsc_rxerr, 0 mpsc_rlsc, 0 mpsc_rhnt, 0 mpsc_rfsc
    0 mpsc_rcsc, 0 mpsc_rovr, 0 mpsc_rcdl, 0 mpsc_rckg, 0 mpsc_bper
    0 mpsc_txerr, 0 mpsc_teidl, 0 mpsc_tudr, 0 mpsc_tctsl, 0 mpsc_tckg
    0 sdma_rx_sf, 0 sdma_rx_mfl, 0 sdma_rx_or, 0 sdma_rx_abr, 0 sdma_rx_no
    0 sdma_rx_de, 0 sdma_rx_cdl, 0 sdma_rx_ce, 0 sdma_tx_rl, 0 sdma_tx_ur, 0 sdma_tx_ctsl
    0 sdma_rx_reserr, 0 sdma_tx_reserr
    0 rx_bogus_pkts, rx_bogus_flag FALSE
    0 sdma_tx_ur_processed
    
    tx_limited = 1(2), errata19 count1 - 0, count2 - 0
    Receive Ring
    rxr head (0)(0x15BD6FA0), rxr tail (0)(0x15BD6FA0)
      rmd(15BD6FA0): nbd 15BD6FB0 cmd_sts 80800000 buf_sz 06000000 buf_ptr 15BD7A80
      rmd(15BD6FB0): nbd 15BD6FC0 cmd_sts 80800000 buf_sz 06000000 buf_ptr 15BD80E0
      rmd(15BD6FC0): nbd 15BD6FD0 cmd_sts 80800000 buf_sz 06000000 buf_ptr 15BD8740
      rmd(15BD6FD0): nbd 15BD6FE0 cmd_sts 80800000 buf_sz 06000000 buf_ptr 15BD8DA0
      rmd(15BD6FE0): nbd 15BD6FF0 cmd_sts 80800000 buf_sz 06000000 buf_ptr 15BD9400
      rmd(15BD6FF0): nbd 15BD7000 cmd_sts 80800000 buf_sz 06000000 buf_ptr 15BD9A60
      rmd(15BD7000): nbd 15BD7010 cmd_sts 80800000 buf_sz 06000000 buf_ptr 15BDA0C0
      rmd(15BD7010): nbd 15BD7020 cmd_sts 80800000 buf_sz 06000000 buf_ptr 15BDA720
    

    Cisco VIRL (Virtual Internet Routing Labo) を VMware Workstation 12.5 にインストールする

    これから CCIE 取得を目指しています。
    まだ CCENTCCNP R&S, ネスペ 認定ですが。。。

    Don’t complicate things.

    とあるように、自分が何やってんのかわかっている場合を除いて余計なことはすんなよと書いてある。

    2016-09-25_19h01_37

    Step 1:  Get Started

    ちなみに VirtualBox には対応していない。
    Vt-x/AMDv が有効になっていることを確認すること。
    つまり Vt-x/AMDv の仮想化が有効になっていることが必須です。

    2016-09-25_19h25_23

    Step 3:  Create and Configure Virtual Networks

    5 つネットワークを作成する。

    VMnet8 は NAT で VIRL 仮想マシンにホスト PC を通じたインターネット接続を提供する。
    その他 4 つのネットワークは VIRL に外部 L2, および L3 のコネクティビティを提供する。
    これらは

    Flat
    Flat1
    SNAT
    クラスタリング INT

    すでに VMnet1 が存在していたらナンバリングを1つずつずらす。
    いずれも ホストオンリーネットワーク とする。

    VMnet1
    172.16.1.0
    255.255.255.0
    ローカル DHCP サービスを使用して IP アドレスを VM に配布するのチェックが外れていることを確認する。

    VMnet2 172.16.2.0/24
    VMnet3 172.16.3.0/24
    VMnet4 172.16.10.0/24

    2016-09-25_19h02_43

    2016-09-25_19h03_20

    2016-09-25_19h03_44

    2016-09-25_19h13_39

    2016-09-25_19h15_30

    最終的に以下のような感じになればいい。

    2016-09-25_19h17_33

    Step 4:  Deploy the VIRL OVA

    いよいよ Cisco VIRL の OVA (Open Virtualization Format Archive) をインポートする。
    事前に VIRL の OVA ファイルとライセンスファイル *.pem ファイルをダウンロードしておくこと。

    https://virl.mediuscorp.com/my-account/

    ちなみに OVA はアニメの Original Video Animation のことではないので注意。
    OVA といいつつハイパーバイザーによってインポートできないことが多々にしてあり、ぜんぜんオープンな気がしないんだよなあ。

    virl.1.2.64.pc.ova

    2016-09-25_19h34_21

    2016-09-25_19h36_58

    VIRL 自身の起動やらなんやらの読み込みは速いことに越したことはないので、新しい仮想マシンのストレージパスには
    容量が許すなら SSD 領域自身を指定することを強くおすすめする。

    2016-09-25_19h40_38

    インポートが終わるまで適当に時間を潰す。

    2016-09-25_19h42_04

    インポート完了、やったね。

    2016-09-25_19h44_29

    VIRL を起動したい気持ちを抑えて設定を確認・調整する。

    2016-09-25_19h45_07

    2016-09-25_19h51_00

    最初のネットワークアダプタは NAT になっているのを確認したらそのままそっとしておく。
    ネットワークアダプタ2~5はインポート直後はブリッジになっているので、さっき作った VMnet1~4 にそれぞれ対応付ける。

    2016-09-25_19h59_56

    次に Intel VT-x/EPT の仮想化が有効になっていることを確認する。

    2016-09-25_20h26_40

    そして最後はCPUとメモリ。
    潤沢にあればあるほどいい。

    最低限のスペックは 2 vCPU、 4GB だが、4 vCPU, 8GB かそれ以上のリソースを割り当てることが要求されている。
    VMware Workstation の推奨メモリ容量は無視しろと書いてある。
    特に他に立ち上げる VM も今のところ考えていないので私は 8vCPU, 16GB の割当てをおこなった。

    2016-09-25_20h30_38

    Step 5:  Prepare VIRL for Activation

    VM を起動して ID: virl PASS: VIRL でログイン。

    2016-09-25_20h34_28

    ログイン後に表示される画面。バイオハザードマークが禍々しい。
    おもむろに xterm を立ち上げる。

    2016-09-25_20h35_27

    以下のコマンドを入力して出力が以下のように出ればひとまずここまでの手順は OK 。
    KVM (Kernel Based Virtual Machine) のアクセラレーション利用可能の表示が出なければ何かがおかしいので手順に沿ってやったか見直せと書いてある。

    virl@virl:~$ sudo kvm-ok
    INFO: /dev/kvm exists
    KVM acceleration can be used
    

    2016-09-25_20h40_54

    次にインターネットへの接続性を確認する。
    VIRL は定期的に Cisco の SaltStack サーバーと通信をしてアクティベーションの妥当性を確認する必要がある。

    ping -c 4 www.cisco.com
    curl http://curltools.com/get-ip
    wget --spider --no-verbose http://www.google.com
    

    2016-09-25_20h45_14

    VIRL のインストラクションにはないが、ここでひとつチューニングをしておく。
    VIRL の割当メモリを使い果たすまで Swap を使うなという設定を入れる。
    別にすぐ VIRL を割当メモリ目いっぱいまで酷使するわけでなければこの手順はすっ飛ばしてかまわない。
    公式の手順にも載ってないし。

    virl@virl:~$ sudo -i
    root@virl:~# cat /proc/sys/vm/swappiness 
    60
    

    キーボードが英字配列になっていることに注意をする。
    イコールは日本語キーボードの場合チルダ ~ のキーを Shift 無しでタイプした時に出てくる。
    また、保存するときのコロン : はセミコロン ; のキーを Shift キー押しながらタイプすると入力できる。
    また、 vi は vim でないことに注意する。
    とても使いづらい。

    root@virl:~# vi /etc/sysctl.conf
    
    vm.swappiness = 1
    root@virl:~# sysctl -p
    net.ipv4.conf.default.rp_filter = 0
    net.ipv4.conf.all.rp_filter = 0
    net.ipv4.ip_forward = 1
    vm.swappiness = 1
    root@virl:~# cat /proc/sys/vm/swappiness 
    1
    root@virl:~# exit
    

    中身をちょっと見るとわかるが、 Ubuntu Linux 14.04 LTS (Trusty) がベースとなっており、 OpenStack がインストールされているようだ。
    なるほどなあ。

    virl@virl:~$ cat /etc/debian_version 
    jessie/sid
    virl@virl:~$ cat /etc/lsb-release 
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=14.04
    DISTRIB_CODENAME=trusty
    DISTRIB_DESCRIPTION="Ubuntu 14.04.4 LTS"
    

    Step 6:  Activate VIRL

    VIRL の IP アドレスを調べてホスト側のブラウザからその IP にアクセスする。

    2016-09-25_21h04_45

    Web 管理画面が見えるはず。
    圧倒的 Bootstrap 感。

    2016-09-25_21h07_23

    User Workspace Management を選択し、以下のログイン情報を入力する。

    ID: uwmadmin
    PASS: password

    2016-09-25_21h10_05

    2016-09-25_21h12_10

    各フィールドを埋める。

    Salt ID and domain には pem ファイルの拡張子抜きのファイル名を、
    Customer email Address は読んで字のごとく、
    List of Cisco salt masters は地理的に近いものを適当に選んで突っ込む。
    正直日本の場合 us のほうでとくに問題はないと思われる。

    us-1.virl.info, us-2.virl.info, us-3.virl.info, us-4.virl.info
    eu-1.virl.info, eu-2.virl.info, eu-3.virl.info, eu-4.virl.info

    Master sign public key はドントタッチミー。
    Minion private RSA key in PEM format には pem ファイルの中身をまんまコピペする。

    そして Reset ボタンクリック。

    2016-09-25_21h21_42

    どこか 1 つでも Salt サーバーとライセンスの検証ができていれば OK 。

    2016-09-25_21h25_35

    Step 7:  Customize the VIRL Configuration (Optional)

    特筆して変更するところはないが、 16GB より多くのメモリを搭載しているなら RAMdisk オプションが使えるようだ。
    インメモリディスクを使用することで、シミュレーションのスタートアップタイムを減らせるらしい。
    速いに越したことはないのでここでさらにメモリを 16GB -> 24GB にして RAMdisk をオンにした。

    24 * 1024 = 24576 MB

    2016-09-25_21h38_20

    まずメンテナンスモードを有効にしろとある。
    メンテナンスモードを有効にする。
    そして Apply 。

    2016-09-25_21h40_59

    オールグリーンになったらシステムリブートしろやと出てくるので、おとなしく再起動する。
    WebUI 上の Reboot ボタンを押すだけで VIRL 仮想マシンをリブートできるみたい。
    素晴らしいな・・・。

    2016-09-25_21h44_07

    リブート終わったら Disable maintenance mode にし、 OK ボタンをクリック

    2016-09-25_21h46_21

    Step 8:  Validate the VIRL Installation

    VIRL が正しくインストール・設定できたことを以下のコマンドで検証せよとある。

    OpenStack の Neutron ネットワーキングモジュールの動作確認ですね。
    xterm をおもむろに立ち上げる。
    alive のところが全部スマイリーマーク :-) になっていれば OK 。

    virl@virl:~$ neutron agent-list
    +--------------------------------------+--------------------+------+-------+----------------+---------------------------+
    | id                                   | agent_type         | host | alive | admin_state_up | binary                    |
    +--------------------------------------+--------------------+------+-------+----------------+---------------------------+
    | 73edf60e-2951-4dfb-8ce7-a2fa58f9199a | DHCP agent         | virl | :-)   | True           | neutron-dhcp-agent        |
    | be125ca6-3381-4e8a-95d1-6de54bd99788 | Linux bridge agent | virl | :-)   | True           | neutron-linuxbridge-agent |
    | c3195bd1-f054-4a0b-85ae-3935ecbe260f | Metadata agent     | virl | :-)   | True           | neutron-metadata-agent    |
    | defeaa84-8b4c-4c5c-b101-b1555520a710 | L3 agent           | virl | :-)   | True           | neutron-l3-agent          |
    +--------------------------------------+--------------------+------+-------+----------------+---------------------------+
    

    2016-09-25_21h52_43

    そして VIRL STD と UWM サービスがすべて listening ステートになっていることを確認する。
    インメモリ KVS である Redis も内部で動いていることが見て取れる。

    virl@virl:~$ sudo virl_health_status | grep listening
    ...
    (snip)
    virl-vis-webserver listening on port 19402
    ank-cisco-webserver listening on port 19401
    STD server on url http://localhost:19399 is listening, server version 0.10.27.8
    UWM server on url http://localhost:19400 is listening, server version 0.10.27.8
    Webmux server on url http://localhost:19403 is listening
    Redis server on 127.0.0.1:6379 is listening
    

    2016-09-25_21h56_55

    Display the VIRL license configuration

    以下の点を確認する。

    ‘hostid’ が pem ファイルのファイル名部分と同じになっていること
    ‘product-capacity’ がライセンス上で許可されているノード数(私の場合は 30 )になっていること
    ‘product-expires’ ‘7’ となっていること。(7 日で切れるということ。切れたらまたソルトサーバーにバリデートしにいく)

    virl@virl:~$ sudo virl_health_status | grep -A 4 -e hostid -e product
    ...
    (snip)
    hostid : ********.virl***.info
    product-license : [u'us-1.virl.info', u'us-2.virl.info', u'us-3.virl.info', u'us-4.virl.info']
    product-capacity : 30
    product-expires : 7
    features : [u'Cariden.MATE.import', u'Cariden.MATE.export']
    product-usage : 0
    uwm-url : http://192.168.200.128:19400/admin/salt/
    

    2016-09-25_22h06_04

    Step 8:  Install and Configure VM Maestro

    ネットワークのトポロジを作成、シミュレーションするツール、 VM Maestro をインストールする。
    Maestro とは芸術家、専門家、音楽の指揮者等の意味があるようだ。

    というか、 VM Maestro のスプラッシュに指揮者のシルエットが出るようになっている。 最近はスプラッシュが出なくなったようだ。

    2016-09-25_22h38_53

    ブラウザで VIRL Server の WebUI にアクセスして、 VM Maestro クライアントをインストールするプラットフォームに応じたバイナリをダウンロードする。
    ここでは Windows x64 アーキテクチャと仮定する(たぶんそんなに変わらない)。

    2016-09-25_22h09_41

    2016-09-25_22h11_30

    ダウンロードしたやつを普通にインストール。

    これもベースは Eclipse となっている。
    オープンソース活用しまくりだな。

    VM Maestro を立ち上げてライセンスアグリーメントに同意して、匿名のレポート送るか聞かれるので、チェックを入れてやめろとしておく。
    文字化けしてるし。

    こいつはクライアントなので、先程 VMware Workstation 上にインストールした VIRL サーバーなしには生きていけない。
    接続先を VIRL サーバーに変えてやる必要がある。

    2016-09-25_22h14_41

    ID, パスワードは以下でよい、 IP アドレスはさっき調べた VIRL サーバーの IP アドレスを入力。

    ID: guest
    PASS: guest

    そしてサービスへの接続チェックがオールグリーンになれば OK 。

    2016-09-25_22h20_33

    なんか Eclipse の Secure Storage にマスターパスワードが保存されたらしいので、リカバリ用の秘密の質問を入力するか聞かれるのでとりあえず Yes としておいた。

    2016-09-25_22h21_49

    2016-09-25_22h23_30

    最後にやること

    以下の手順で Node Subtype の一覧をデフォルトにリセットして、 VIRL ホストで利用可能な node sub-types をすべて再取得する必要がある。

    File -> Preferences を開く。
    まずは Restore Defaults でリセットする。

    2016-09-25_22h30_49

    そして VIRL サーバーからサブタイプの一覧を取得する。

    2016-09-25_22h32_45

    シミュレーションをちょっとやってみよう

    RAMdisk を enable にした状態。
    8 vCPU
    24 GB

    すべてのノードが起動するまでに要した時間はおよそ 1 分程度。

    (INFO) [Sep/25/2016 13:43:37] simulation "topology-97p7fh": nodes can start
    (INFO) [Sep/25/2016 13:43:43] Starting node "~mgmt-lxc"
    (INFO) [Sep/25/2016 13:43:44] Starting node "iosv-1"
    (INFO) [Sep/25/2016 13:43:49] Starting node "iosv-2"
    (INFO) [Sep/25/2016 13:43:54] Starting node "iosv-3"
    (INFO) [Sep/25/2016 13:44:00] Starting node "iosvl2-1"
    (INFO) [Sep/25/2016 13:44:07] Starting node "server-1"
    (INFO) [Sep/25/2016 13:44:07] Node "iosv-1" state changed from ABSENT to ACTIVE
    (INFO) [Sep/25/2016 13:44:07] Node "iosv-2" state changed from ABSENT to ACTIVE
    (INFO) [Sep/25/2016 13:44:07] Node "iosv-3" state changed from ABSENT to ACTIVE
    (INFO) [Sep/25/2016 13:44:07] Node "iosvl2-1" state changed from ABSENT to BUILDING
    (INFO) [Sep/25/2016 13:44:07] Node "~mgmt-lxc" state changed from ABSENT to ACTIVE
    (INFO) [Sep/25/2016 13:44:12] Starting node "server-2"
    (INFO) [Sep/25/2016 13:44:17] Starting node "server-3"
    (INFO) [Sep/25/2016 13:44:36] Node "iosvl2-1" state changed from BUILDING to ACTIVE
    (INFO) [Sep/25/2016 13:44:36] Node "server-1" state changed from ABSENT to ACTIVE
    (INFO) [Sep/25/2016 13:44:36] Node "server-2" state changed from ABSENT to ACTIVE
    (INFO) [Sep/25/2016 13:44:36] Node "server-3" state changed from ABSENT to ACTIVE
    

    ルーター右クリックでコンソールポートに接続できる。

    2016-09-25_22h57_16

    10.1.0.0/24 のマルチアクセスネットワークを想定して IP アドレスをルーターに設定して ping を打ってみたところ。

    2016-09-25_22h54_57

    お疲れ様でした。

    Tips

    あとの普段のシミュレーション自体は VIRL の仮想マシンが立ち上がっていればよいので、とくに Linux にログインする必要もなければ、 WebUI にログインする必要もない。

    参考サイト

    1. VIRL via VMware Workstation
    2. VIRL | CCIEおじさん日記

    CCENT 合格した(ICND1 v3.0, 100-105J)

    100-105 – Interconnecting Cisco Networking Devices Part 1

    CCENT合格!新試験の下見で来たからあんまり期待してなかったけど、合格できてよかった。

    いきなりCCNAはやっぱり無謀みがある。

    ICND1は旧試験の知識(ICND1, ICND2両方)とシミュレーション3問ぐらい出るって知っていればなんとか解けた。
    スコアは903程度。
    今回はマーカーボードも活用した。
    腹が減っていたので近くのすき家で牛丼大盛りをかきこんで満たされてからいざ試験会場へ。
    試験センターで当日その場で予約して現金払いした。
    RFCの規格番号答える問題は年表覚えるみたいでやっぱり苦手だな。
    フレームリレーは無くなったけど、相変わらずシリアル接続は出てきたので注意が必要。
    真新しい点としては無線の設問が出たくらいかな。
    でも常識的な単語知ってれば解ける問題なので大丈夫だった。
    それより2万近い受験料が痛い。。。
    受かってよかったわ。

    あと、RIPv2 がシミュレーション問題で出てきた。

    Cisco Catalyst 3750v2, 2960 で作る L3 スイッチでの VLAN 間ルーティング

    Router on a Stick 構成ではなく、 L3 スイッチで VLAN 間ルーティングを行う場合の設定。
    ASW 2 台と L3 スイッチ 1 台で構成する。
    IOS のバージョンはすべて 15 系。
    VLAN 間の通信の制限とかは ACL でやるのかな。

    ASW1

    ASW1(config)#vlan 10,20
    ASW1(config-vlan)#exit
    ASW1(config)#int range
    *Mar  1 06:54:34.872: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
    ASW1(config)#int range
    *Mar  1 06:54:35.871: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to down
    ASW1(config)#int range
    *Mar  1 06:54:38.270: %LINK-3-UPDOWN: Interface FastEthernet0/8, changed state to up
    ASW1(config)#int range
    *Mar  1 06:54:38.354: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
    *Mar  1 06:54:39.276: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to up
    ASW1(config)#int range
    *Mar  1 06:54:39.352: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to down
    *Mar  1 06:54:40.753: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down
    ASW1(config)#int range
    *Mar  1 06:54:40.996: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
    *Mar  1 06:54:41.751: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to down
    *Mar  1 06:54:42.003: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
    ASW1(config)#int range
    *Mar  1 06:54:45.073: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
    ASW1(config)#int range
    *Mar  1 06:54:45.350: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up
    ASW1(config)#int range
    *Mar  1 06:54:46.071: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down
    *Mar  1 06:54:46.356: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
    ASW1(config)#int range
    *Mar  1 06:54:47.069: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to down
    ASW1(config)#int range
    *Mar  1 06:54:51.389: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
    *Mar  1 06:54:52.396: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
    ASW1(config)#int range
    *Mar  1 06:55:06.296: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
    ASW1(config)#int range fa 0/1-3
    ASW1(config-if-range)#swi
    ASW1(config-if-range)#switchport mod
    ASW1(config-if-range)#switchport mode ac
    ASW1(config-if-range)#switchport mode access
    ASW1(config-if-range)#exit
    ASW1(config)#int fa 0/2
    ASW1(config-if)#swi
    ASW1(config-if)#switchport a
    ASW1(config-if)#switchport ac
    ASW1(config-if)#switchport access vl
    ASW1(config-if)#switchport access vlan 10
    ASW1(config-if)#int fa 0/3
    ASW1(config-if)#swi
    ASW1(config-if)#switchport ac
    ASW1(config-if)#switchport access vl
    ASW1(config-if)#switchport access vlan 20
    ASW1(config-if)#int fa 0/8
    ASW1(config-if)#swi
    ASW1(config-if)#switchport mo
    ASW1(config-if)#switchport mode tru
    ASW1(config-if)#switchport mode trunk
    ASW1(config-if)#
    *Mar  1 07:07:04.730: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to down
    ASW1(config-if)#
    *Mar  1 07:07:07.750: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to up
    ASW1(config-if)#swi
    ASW1(config-if)#switchport tru
    ASW1(config-if)#switchport trunk na
    ASW1(config-if)#switchport trunk native v
    ASW1(config-if)#switchport trunk native vlan 99
    ASW1(config-if)#swi
    ASW1(config-if)#switchport
    *Mar  1 07:07:30.508: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 1 on FastEthernet0/8 VLAN99.
    *Mar  1 07:07:30.508: %SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet0/8 on VLAN0001. Inconsistent peer vlan.
    *Mar  1 07:07:30.508: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/8 on VLAN0099. Inconsistent local vlan.
    ASW1(config-if)#switchport none
    ASW1(config-if)#switchport nonegotiate
    ASW1(config-if)#
    *Mar  1 07:08:15.815: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
    ASW1(config-if)#exit
    ASW1(config)#int vlan 1
    ASW1(config-if)#ip add
    ASW1(config-if)#ip address 172.17.1.100
    *Mar  1 07:09:15.819: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
    ASW1(config-if)#ip address 172.17.1.100 255.255.255.0
    ASW1(config-if)#no shut
    ASW1(config-if)#
    *Mar  1 07:10:15.822: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
    ASW1(config-if)#exit
    ASW1(config)#ip defa
    ASW1(config)#ip default-gateway 172.17.1.254 255.255.255.0
                                                 ^
    % Invalid input detected at '^' marker.
    
    ASW1(config)#ip default-gateway 172.17.1.254
    ASW1(config)#exit
    *Mar  1 07:11:15.826: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
    ASW1(config)#exit
    ASW1#
    *Mar  1 07:11:18.620: %SYS-5-CONFIG_I: Configured from console by console
    ASW1#
    *Mar  1 07:12:15.830: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
    ASW1#
    *Mar  1 07:12:20.184: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/8 on VLAN0001. Port consistency restored.
    *Mar  1 07:12:20.184: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/8 on VLAN0099. Port consistency restored.
    ASW1#
    *Mar  1 07:13:04.626: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
    ASW1#
    *Mar  1 07:13:05.658: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 1 on FastEthernet0/8 VLAN99.
    *Mar  1 07:13:05.658: %SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet0/8 on VLAN0001. Inconsistent peer vlan.
    *Mar  1 07:13:05.658: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/8 on VLAN0099. Inconsistent local vlan.
    ASW1#
    *Mar  1 07:13:13.560: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
    *Mar  1 07:13:14.567: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
    ASW1#
    *Mar  1 07:13:15.574: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
    ASW1#
    *Mar  1 07:13:16.580: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
    ASW1#
    *Mar  1 07:13:17.587: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
    ASW1#
    *Mar  1 07:13:18.593: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
    ASW1#
    *Mar  1 07:13:19.600: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
    ASW1#
    *Mar  1 07:13:20.607: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/1 (1).
    ASW1#
    *Mar  1 07:14:08.808: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/8 on VLAN0001. Port consistency restored.
    *Mar  1 07:14:08.808: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/8 on VLAN0099. Port consistency restored.
    

    ASW2

    ASW2#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    ASW2(config)#vlan 10,20
    ASW2(config-vlan)#exit
    ASW2(config)#
    *Mar  1 06:54:50.819: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
    ASW2(config)#
    *Mar  1 06:54:51.817: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to down
    ASW2(config)#
    *Mar  1 06:54:54.703: %LINK-3-UPDOWN: Interface FastEthernet0/8, changed state to up
    *Mar  1 06:54:55.710: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to up
    ASW2(config)#
    *Mar  1 06:54:58.184: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
    ASW2(config)#
    *Mar  1 06:54:59.183: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to down
    ASW2(config)#
    *Mar  1 06:55:00.105: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down
    ASW2(config)#
    *Mar  1 06:55:00.818: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
    *Mar  1 06:55:01.103: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to down
    ASW2(config)#
    *Mar  1 06:55:01.707: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
    *Mar  1 06:55:01.825: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
    *Mar  1 06:55:02.706: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down
    ASW2(config)#
    *Mar  1 06:55:02.739: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up
    *Mar  1 06:55:03.704: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to down
    *Mar  1 06:55:03.746: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
    ASW2(config)#
    *Mar  1 06:55:05.180: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
    *Mar  1 06:55:06.187: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
    ASW2(config)#
    *Mar  1 06:55:22.729: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
    ASW2(config)#int range fa 0/1-3
    ASW2(config-if-range)#switchport mode access
    ASW2(config-if-range)#exit
    ASW2(config)#int fa 0/2
    ASW2(config-if)#swi
    ASW2(config-if)#switchport ac
    ASW2(config-if)#switchport access vl
    ASW2(config-if)#switchport access vlan 10
    ASW2(config-if)#int fa 0/3
    ASW2(config-if)#swi
    ASW2(config-if)#switchport a
    ASW2(config-if)#switchport ac
    ASW2(config-if)#switchport access v
    ASW2(config-if)#switchport access vlan 2
    ASW2(config-if)#switchport access vlan 20
    ASW2(config-if)#int fa 0/8
    ASW2(config-if)#swi
    ASW2(config-if)#switchport mo
    ASW2(config-if)#switchport mode tru
    ASW2(config-if)#switchport mode trunk
    ASW2(config-if)#
    *Mar  1 07:07:12.498: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to down
    ASW2(config-if)#
    *Mar  1 07:07:15.518: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, changed state to up
    ASW2(config-if)#switchport trunk native vlan 99
    ASW2(config-if)#
    *Mar  1 07:07:46.598: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 1 on FastEthernet0/8 VLAN99.
    *Mar  1 07:07:46.598: %SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet0/8 on VLAN0001. Inconsistent peer vlan.
    *Mar  1 07:07:46.598: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/8 on VLAN0099. Inconsistent local vlan.
    ASW2(config-if)#switchport nonegotiate
    ASW2(config-if)#
    *Mar  1 07:08:23.583: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
    ASW2(config-if)#exit
    ASW2(config)#
    *Mar  1 07:09:23.595: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
    ASW2(config)#int vlan 1
    ASW2(config-if)#ip address 172.17.1.101 255.255.255.0
    ASW2(config-if)#no shut
    ASW2(config-if)#exit
    ASW2(config)#
    *Mar  1 07:10:23.599: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
    ASW2(config)#ip default-gateway 172.17.1.254
    ASW2(config)#exit
    ASW2#
    *Mar  1 07:11:22.042: %SYS-5-CONFIG_I: Configured from console by console
    ASW2#
    *Mar  1 07:11:23.602: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
    ASW2#
    *Mar  1 07:12:23.598: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
    ASW2#
    *Mar  1 07:12:58.738: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/8 on VLAN0001. Port consistency restored.
    *Mar  1 07:12:58.738: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/8 on VLAN0099. Port consistency restored.
    ASW2#
    *Mar  1 07:13:04.719: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
    ASW2#
    *Mar  1 07:13:05.725: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 1 on FastEthernet0/8 VLAN99.
    *Mar  1 07:13:05.725: %SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet0/8 on VLAN0001. Inconsistent peer vlan.
    *Mar  1 07:13:05.725: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/8 on VLAN0099. Inconsistent local vlan.
    ASW2#
    *Mar  1 07:13:13.636: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
    *Mar  1 07:13:14.642: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
    ASW2#
    *Mar  1 07:13:15.649: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
    ASW2#
    *Mar  1 07:13:16.656: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
    ASW2#
    *Mar  1 07:13:17.662: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
    *Mar  1 07:13:18.669: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
    ASW2#
    *Mar  1 07:13:19.676: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
    ASW2#
    *Mar  1 07:13:20.682: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/8 (99), with DSW FastEthernet1/0/2 (1).
    ASW2#
    *Mar  1 07:14:08.875: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/8 on VLAN0001. Port consistency restored.
    *Mar  1 07:14:08.875: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/8 on VLAN0099. Port consistency restored.
    ASW2#
    *Mar  1 07:19:48.739: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down
    *Mar  1 07:19:49.746: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to down
    ASW2#
    *Mar  1 07:19:52.019: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
    *Mar  1 07:19:53.026: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
    

    DSW

    DSW(config)#vlan 10,20,99
    DSW(config-vlan)#exit
    DSW(config)#int
    *Mar  1 07:11:31.966: %SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet1/0/1 VLAN1.
    *Mar  1 07:11:31.966: %SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet1/0/1 on VLAN0001. Inconsistent port type.
    DSW(config)#int range fa 0/1-2
                               ^
    % Invalid input detected at '^' marker.
    
    DSW(config)#int range fa 10/1-2
    *Mar  1 07:11:48.114: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet1/0/2 (1), with ASW2 FastEthernet0/8 (99).
    DSW(config)#int range fa 1/0/1-2
    DSW(config-if-range)#swi
    DSW(config-if-range)#switchport tr
    DSW(config-if-range)#switchport trunk enca
    DSW(config-if-range)#switchport trunk encapsulation do
    DSW(config-if-range)#switchport trunk encapsulation dot1q
    DSW(config-if-range)#
    *Mar  1 07:12:09.840: %SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet1/0/2 VLAN1.
    *Mar  1 07:12:09.840: %SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet1/0/2 on VLAN0001. Inconsistent port type.
    DSW(config-if-range)#swi
    DSW(config-if-range)#switchport mo
    DSW(config-if-range)#switchport mode tr
    DSW(config-if-range)#switchport mode trunk
    DSW(config-if-range)#
    *Mar  1 07:12:26.190: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1, changed state to down
    *Mar  1 07:12:26.198: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/2, changed state to down
    DSW(config-if-range)#
    *Mar  1 07:12:29.218: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1, changed state to up
    *Mar  1 07:12:29.243: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/2, changed state to up
    DSW(config-if-range)#
    *Mar  1 07:12:29.898: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 99 on FastEthernet1/0/2 VLAN1.
    *Mar  1 07:12:29.898: %SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet1/0/2 on VLAN0099. Inconsistent peer vlan.
    *Mar  1 07:12:29.898: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet1/0/2 on VLAN0001. Inconsistent local vlan.
    *Mar  1 07:12:30.107: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 99 on FastEthernet1/0/1 VLAN1.
    *Mar  1 07:12:30.107: %
    DSW(config-if-range)#SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet1/0/1 on VLAN0099. Inconsistent peer vlan.
    *Mar  1 07:12:30.107: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet1/0/1 on VLAN0001. Inconsistent local vlan.
    DSW(config-if-range)#
    *Mar  1 07:12:40.417: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet1/0/1 (1), with ASW1 FastEthernet0/8 (99).
    DSW(config-if-range)#s
    *Mar  1 07:12:48.118: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet1/0/2 (1), with ASW2 FastEthernet0/8 (99).
    DSW(config-if-range)#swi
    DSW(config-if-range)#switchport tru
    DSW(config-if-range)#switchport trunk na
    DSW(config-if-range)#switchport trunk native 99
                                                   ^
    % Invalid input detected at '^' marker.
    
    DSW(config-if-range)#switchport trunk native ?
      vlan  Set native VLAN when interface is in trunking mode
    
    DSW(config-if-range)#switchport trunk native v
    DSW(config-if-range)#switchport trunk native vlan 9
    DSW(config-if-range)#switchport trunk native vlan 99
    DSW(config-if-range)#swi
    DSW(config-if-range)#switchport none
    DSW(config-if-range)#switchport nonegotiate
    DSW(config-if-range)#exit
    DSW(config)#ip ro
    DSW(config)#ip rout
    *Mar  1 07:13:33.039: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet1/0/2 on VLAN0099. Port consistency restored.
    *Mar  1 07:13:33.039: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet1/0/2 on VLAN0001. Port consistency restored.
    *Mar  1 07:13:33.232: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet1/0/1 on VLAN0099. Port consistency restored.
    *Mar  1 07:13:33.232: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet1/0/1 on VLAN0001. Port consistency restored.
    DSW(config)#ip routi
    DSW(config)#ip routing
    *Mar  1 07:14:03.061: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
    DSW(config)#ip routing
    DSW(config)#int vlan 1
    DSW(config-if)#ip add
    DSW(config-if)#ip address 172.17.1.254 255.255.255.0
    DSW(config-if)#no shut
    DSW(config-if)#int vlan 10
    DSW(config-if)#
    *Mar  1 07:17:13.458: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
    DSW(config-if)#ip address 172.17.10.254 255.255.255.0
    DSW(config-if)#no shut
    DSW(config-if)#int vlan 20
    DSW(config-if)#
    *Mar  1 07:17:28.524: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
    DSW(config-if)#ip address 172.17.20.254 255.255.255.0
    DSW(config-if)#no shut
    DSW(config-if)#end
    DSW#
    *Mar  1 07:17:52.985: %SYS-5-CONFIG_I: Configured from console by console
    

    ルーティングテーブルの確認。

    DSW#sh ip route
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
           + - replicated route, % - next hop override
    
    Gateway of last resort is not set
    
          172.17.0.0/16 is variably subnetted, 6 subnets, 2 masks
    C        172.17.1.0/24 is directly connected, Vlan1
    L        172.17.1.254/32 is directly connected, Vlan1
    C        172.17.10.0/24 is directly connected, Vlan10
    L        172.17.10.254/32 is directly connected, Vlan10
    C        172.17.20.0/24 is directly connected, Vlan20
    L        172.17.20.254/32 is directly connected, Vlan20